summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-0.6.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-ros/genpy/genpy-0.6.16.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.16.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.16.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/genpy/genpy-0.6.16.ebuild b/dev-ros/genpy/genpy-0.6.16.ebuild
new file mode 100644
index 000000000000..e8cda9d3e500
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.16.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="https://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )