summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest2
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild17
2 files changed, 6 insertions, 13 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 945e57c567ab..ab1fa321cb17 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1,3 +1,3 @@
DIST sphinxcontrib-spelling-7.2.1.tar.gz 49584 BLAKE2B 7211acfe344b157c0d44f356aef4c31fabcb1b30256cec1693fa67d2652d80c8f3657441c193f82ef26e0e7acd7d141732bef0704462a292355d70a18ab3c2be SHA512 e9b9709b627545e1191d64753c97c0cf65e100d5379e7cc1da46faf9c5d5ea0eeb6c7aafe99331f9518488fb0801c245e0c1fa9853360bb6cf373515a4fed2ed
-EBUILD sphinxcontrib-spelling-7.2.1.ebuild 1249 BLAKE2B 8bcabf8515709d06a98eb28abf0361f4445b1eb2e02279fd79be8a755946a430877af0c572e4607dcc42c96cdd9a7e153c9054ca8f26d6989bdffa0b71389dbd SHA512 82e1fb7eb4a5ce5c811517f3733c69a45c836b6a515843d3c5ab161b3fb1ae0fc67bd6281dec6c6372bb13d0230243bbf563474f6861e355882143a402687485
+EBUILD sphinxcontrib-spelling-7.2.1.ebuild 1091 BLAKE2B 23635ac63b9beb80c4f7203856d2175f478421f5c2c9f1e906a7403063571f767d7291491054db6a434d7c31429925d697c67583bc61f64a99506b194d45e69a SHA512 2c1d241cd97a2e665a855e13a01c2ddd5542b9ab21da2525bccb2ed8a9e040effa87acf123946bd0b9b8c668119cfd59faaa42822f5d83e80c6b749feb60b43d
MISC metadata.xml 450 BLAKE2B a64fc81ee1b159f6ad2d8fe754cfbb8be207a77d128d01cb7cc0d46b6ba4deea1e49e49654a6b0759699d4dbddcede66cb38457c0b476e4120eb3bd5d34cd37b SHA512 0decb41e64275e11d327f2025732865ac4469b7dffe45386b100f6813df5554e71097bd957f57331856d64c9c8c89ad371abfbb25e0db54f3bf7efe2c85ad1ec
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
index 668e2c8538ae..e499df72fce5 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,9 +16,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
- ' python3_{6,7})
dev-python/pyenchant[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
"
@@ -32,6 +29,10 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ tests/test_filter.py::test_contributors
+)
+
# We don't want distutils_enable_tests to add the namespace
# package to BDEPEND under "test?". Therefore we add it to RDEPEND
# after running distutils_enable_tests.
@@ -39,14 +40,6 @@ RDEPEND+="
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
"
-python_test() {
- local deselect=(
- tests/test_filter.py::test_contributors
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
-
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die