summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
index 668e2c8538ae..e499df72fce5 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,9 +16,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
- ' python3_{6,7})
dev-python/pyenchant[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
"
@@ -32,6 +29,10 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ tests/test_filter.py::test_contributors
+)
+
# We don't want distutils_enable_tests to add the namespace
# package to BDEPEND under "test?". Therefore we add it to RDEPEND
# after running distutils_enable_tests.
@@ -39,14 +40,6 @@ RDEPEND+="
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
"
-python_test() {
- local deselect=(
- tests/test_filter.py::test_contributors
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
-
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die