summaryrefslogtreecommitdiff
path: root/dev-python/python-fcl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fcl')
-rw-r--r--dev-python/python-fcl/Manifest4
-rw-r--r--dev-python/python-fcl/files/python-fcl-0.0.12-fix-compiling-on-lld.patch12
-rw-r--r--dev-python/python-fcl/metadata.xml17
-rw-r--r--dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild31
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/python-fcl/Manifest b/dev-python/python-fcl/Manifest
new file mode 100644
index 000000000000..39d222ce23b6
--- /dev/null
+++ b/dev-python/python-fcl/Manifest
@@ -0,0 +1,4 @@
+AUX python-fcl-0.0.12-fix-compiling-on-lld.patch 400 BLAKE2B d50568d13ad303c9c56a604d5ff8bcfaa537298cbda7b48628c07637ae7364aedf88fb57a04c601765ef1ff5280d609fc50dd06270d9cce32085f19d3c3b1e08 SHA512 4e668d7ac21a0fd326db170d64a3ac0cd931dfd5657546682033c30ad86d7d29ad845a5be4110b8cae2cdfd5ad1a784f3792eb7a8b0fd665f17614dab30a0c9b
+DIST python-fcl-0.0.12.tar.gz 17204 BLAKE2B 594d466270160e71e67d99f1745b382c3b1f7754adeb9ba58443e4370e14496e45f4a7619eb7d41db22766f75fe841e088609014bf5a9ff5a6b7ee526b34eca2 SHA512 3b5462206e63e17c646edeeedb268474cc6df1ff12d64d4de0c46bcc281787a42b6306778d2fe5d4d3b2e23bc0ed86e092c9a39b74d019638c771ac5c9d9f8ce
+EBUILD python-fcl-0.0.12-r1.ebuild 704 BLAKE2B 2802f12c54504eb8fd1aaf60309859d869ea14e5c98f0c0fa4a58b54af430d2b48a1154d181f625f5b29ffecfa25ff14d624d68dd569ce16d9d8a11d970be3a7 SHA512 04bb1edb36e3cb905ecd298850825aae356f6c32df0fb3af226ede26dabcb9cb0c5df20b13db76a70bc8c97a6be43b41303ffec9cae2df7baf82167a9af7dc0a
+MISC metadata.xml 773 BLAKE2B 4f7a9b4f37e8cd1347baa2db7cc3db2cbcf352efe48ee7b1157415dc3b1b9b740d68dc5d7e19511844c746e7805ebfbed8d881e2f7f67be5ece8751500377c03 SHA512 a960dcc325f02e948d21ede4566e19d252ffd24a517e4ad58341c8f1e86985ab16cdf488c579119a6d31a7cc39024e00654baaebb2814252a9b6a97e851726dc
diff --git a/dev-python/python-fcl/files/python-fcl-0.0.12-fix-compiling-on-lld.patch b/dev-python/python-fcl/files/python-fcl-0.0.12-fix-compiling-on-lld.patch
new file mode 100644
index 000000000000..0e3cf7a54196
--- /dev/null
+++ b/dev-python/python-fcl/files/python-fcl-0.0.12-fix-compiling-on-lld.patch
@@ -0,0 +1,12 @@
+--- a/setup.py
++++ b/setup.py
+@@ -21,8 +21,7 @@
+ include_dirs = ['/usr/include',
+ '/usr/local/include',
+ '/usr/include/eigen3']
+- lib_dirs = ['/usr/lib',
+- '/usr/local/lib']
++ lib_dirs = ['/usr/local/lib']
+
+ if 'CPATH' in os.environ:
+ include_dirs += os.environ['CPATH'].split(':')
diff --git a/dev-python/python-fcl/metadata.xml b/dev-python/python-fcl/metadata.xml
new file mode 100644
index 000000000000..5df3748729e8
--- /dev/null
+++ b/dev-python/python-fcl/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <longdescription>
+ Python-FCL is an (unofficial) Python interface for the Flexible Collision Library (FCL), an excellent C++
+ library for performing proximity and collision queries on pairs of geometric models.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/BerkeleyAutomation/python-fcl/issues</bugs-to>
+ <remote-id type="github">BerkeleyAutomation/python-fcl</remote-id>
+ <remote-id type="pypi">python-fcl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild b/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
new file mode 100644
index 000000000000..950a9e71cccf
--- /dev/null
+++ b/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Flexible Collision Library"
+HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~sci-libs/fcl-0.5.0
+ sci-libs/octomap
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-compiling-on-lld.patch )
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
+}