summaryrefslogtreecommitdiff
path: root/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild')
-rw-r--r--dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild b/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
new file mode 100644
index 000000000000..950a9e71cccf
--- /dev/null
+++ b/dev-python/python-fcl/python-fcl-0.0.12-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Flexible Collision Library"
+HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ~sci-libs/fcl-0.5.0
+ sci-libs/octomap
+"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-compiling-on-lld.patch )
+
+distutils_enable_tests unittest
+
+python_test() {
+ "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
+}