summaryrefslogtreecommitdiff
path: root/dev-python/python-afl
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-afl')
-rw-r--r--dev-python/python-afl/Manifest2
-rw-r--r--dev-python/python-afl/python-afl-0.7.1.ebuild24
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-afl/Manifest b/dev-python/python-afl/Manifest
index 4cd12a5967c5..04f06edca376 100644
--- a/dev-python/python-afl/Manifest
+++ b/dev-python/python-afl/Manifest
@@ -1,3 +1,5 @@
DIST python-afl-0.6.1.tar.gz 14795 BLAKE2B 7899ffb9ee2d0afa82a4621d7c26acd3f19f4711480f4d85a60007d7739f3dcac99a787bc7dea33d2b336e117320cef69037a20c54771ead695eae1771f2b7cb SHA512 25662ae96db23560ab0f7df1468f1a4737f8f68853bed75cfcfe6112a6fac110501c66941402f35686d6b96a6d124a2aeeaed79052d618583843528cb3eee3aa
+DIST python-afl-0.7.1.tar.gz 16045 BLAKE2B 05d0aba389dcdcc11b6ec789f12f8d282b6d2fa4f1706795832468d92aa1c5e9e1c829ed7e5bfaf77bec011098cf9fe30b67c9ac2ce66c0ad5bd84a6c3037f47 SHA512 e0b8d65378d41d8ba654c8b6f3d03822ac18543cb91fb650f35d490c4b72be6b038d1a13341a33cbdde2102ad92a7e533e5c8ade9a9f13d32c78a774d5e7f120
EBUILD python-afl-0.6.1.ebuild 656 BLAKE2B df716be3062c7e6ab3071ee6ab35ac4a4aa22b3a1cc251e3009bf635e4b22cdf8cfb67c371b33eec5920a85ba7f5e070455d9ea919273f24fdace46fdc152072 SHA512 228457a20b3b52cd3e6d9fb2a35c415806c0a6acae42e38b29e00a9f62901fc5aafe552d298b0a7e18aaa24ef7ad9b4e8d41ffd9027ccb007615916c62e47a09
+EBUILD python-afl-0.7.1.ebuild 656 BLAKE2B fa7b72860b192b96764d458df6b1e992492e46c508703d5431c29577af60f35bcdd3a8266813dffc62f711f432f9786b2198a6d70630fe269340b87931e437e9 SHA512 1786e3b9c1b25f231b6c7607667bd95a0fd5a95031e9b0466797fde64cbc595277ecfe0b0140a9bfc1f403e3bb328c4d5ce0e3dd8306ddba02e2d864102913f1
MISC metadata.xml 369 BLAKE2B 17f8688a27fdbd63196d3a5735208a820b9354672c7c0cf4ad7aa9f9968cd0f82246113b7d0f9903b6e6e3e859e77d1a3fc2d989049fc232357e13e1f0b1a46f SHA512 2d9ed7de83ee4bcb366d1f51b9d821a847da2c17f8b83b486a81f9739fa3e4d9071780e9e22342fcb64f9c1d266d9a9003b6fe743daac68f8aba12f0ff6e59cb
diff --git a/dev-python/python-afl/python-afl-0.7.1.ebuild b/dev-python/python-afl/python-afl-0.7.1.ebuild
new file mode 100644
index 000000000000..bf8b847ba196
--- /dev/null
+++ b/dev-python/python-afl/python-afl-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Enables American fuzzy lop fork server and instrumentation for pure-Python code"
+HOMEPAGE="https://github.com/jwilk/python-afl http://jwilk.net/software/python-afl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-forensics/afl"
+DEPEND=">=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PATH="${PATH}:." nosetests --verbose || die
+}