summaryrefslogtreecommitdiff
path: root/dev-python/python-afl/python-afl-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-afl/python-afl-0.7.1.ebuild')
-rw-r--r--dev-python/python-afl/python-afl-0.7.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-afl/python-afl-0.7.1.ebuild b/dev-python/python-afl/python-afl-0.7.1.ebuild
new file mode 100644
index 000000000000..bf8b847ba196
--- /dev/null
+++ b/dev-python/python-afl/python-afl-0.7.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Enables American fuzzy lop fork server and instrumentation for pure-Python code"
+HOMEPAGE="https://github.com/jwilk/python-afl http://jwilk.net/software/python-afl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="app-forensics/afl"
+DEPEND=">=dev-python/cython-0.19[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ PATH="${PATH}:." nosetests --verbose || die
+}