summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest2
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild12
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
index bf56235f825f..83e2371ef6e3 100644
--- a/dev-python/pytest-trio/Manifest
+++ b/dev-python/pytest-trio/Manifest
@@ -1,3 +1,3 @@
DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
-EBUILD pytest-trio-0.7.0.ebuild 1108 BLAKE2B cbf0050f27df6fbbb8f13d0db490b2482548b825ffcef31e1debaeb29452e63186e383e2223f21de664acfb15625d7ee7cc00bf4bc905bae49aa2ee01ce96c66 SHA512 b8f569da05df2ee80f0a42f2bc165f8f1106c83a2eac63023d9575ea66a10779ebb55250160f7b1d20540a290984e68ad700a3145883de49b08eb2c31da33a1d
+EBUILD pytest-trio-0.7.0.ebuild 1341 BLAKE2B 7ebb3372feadbec50109a862502217be37a43e6c66c31643f029628c315c18840612ada69ff9d970f9cf419273cf932bfba2adac6c50f70c9cca1fc8f6159198 SHA512 711e6d3cef4420a00fd607d306c90d1d01531c0b507c10f1cc475922342abbed6a06a5c4b85a21e29ae01ae754dfc4b1c07e2642b7ade4d01a439ce90a077853
MISC metadata.xml 419 BLAKE2B e4bf5b235b2b851e2677e138ab488308deb5265d00afa1c5ff2760e817c7a8c9fdbaeb095bf63ad6c9ff0a5dbb60df5c047b6ab9564c590becb7da76a3258db0 SHA512 1d21a7481afb771ee6507f6475f9460bd0f8441de68987e2a31923091b33bba4a9fe5d6a8ec0b313d8277942656388c1ae6fb9b7cc0de601655762b66b111e0a
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
index 7b70309d75c6..f18e11dd8382 100644
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
>=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
@@ -30,7 +30,7 @@ BDEPEND="
)
"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
distutils_enable_sphinx docs/source \
dev-python/attrs \
dev-python/sphinx_rtd_theme \
@@ -41,3 +41,11 @@ python_prepare_all() {
mv pytest_trio/_tests/conftest.py conftest.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}