summaryrefslogtreecommitdiff
path: root/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-trio/pytest-trio-0.7.0.ebuild')
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
index 7b70309d75c6..f18e11dd8382 100644
--- a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
RDEPEND="
>=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
@@ -30,7 +30,7 @@ BDEPEND="
)
"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
distutils_enable_sphinx docs/source \
dev-python/attrs \
dev-python/sphinx_rtd_theme \
@@ -41,3 +41,11 @@ python_prepare_all() {
mv pytest_trio/_tests/conftest.py conftest.py || die
distutils-r1_python_prepare_all
}
+
+python_test() {
+ # disable autoloading pytest-asyncio in nested pytest calls
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading pytest-trio
+ local -x PYTEST_PLUGINS=pytest_trio.plugin
+ epytest
+}