summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flakes
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-flakes')
-rw-r--r--dev-python/pytest-flakes/Manifest3
-rw-r--r--dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch17
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild25
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/Manifest b/dev-python/pytest-flakes/Manifest
index e59df42f0d9c..ebc012ba9bf3 100644
--- a/dev-python/pytest-flakes/Manifest
+++ b/dev-python/pytest-flakes/Manifest
@@ -1,3 +1,6 @@
+AUX pytest-flakes-4.0.3-fix-py3.10.patch 573 BLAKE2B e956207230016083962085749a698d10d5ae7435daf49472b9543c09cf4c7430ea49715432c396675b9f86c65b5ac429abb8dee2df4ab16b6d13c103bfedf7ea SHA512 fdfab1fb712b8b880ea6e0aa32d82dd247dd78381d5ac11031fe06218835f9cded48d08d675f69a834273e84aa7ab3e2bb36c697f79a39d086cb6d1a9e629c4a
DIST pytest-flakes-4.0.2.tar.gz 7225 BLAKE2B 3a5ec59e3df90b6bf90daf5cf4abdf2946852a8e62a98ed08e5ba93c2e3f9e93699b2a4b571df45edac83e4c1791a5828b0bcca2a26a37b71f01d81bf3f0342f SHA512 bb1fc432e2494367849acedecba80495ede34c18dcf3ada09ef3dec8567d55f8dd6ba427bc3d9e47cfe3c0bb2aba80576612282d5a71858ccb45bce458f8656c
+DIST pytest-flakes-4.0.3.tar.gz 7312 BLAKE2B cf62d7e11a0521592325492c76e67cd51384b31d8a6191f10940230014c9a8797b3603e24664c022add5cec18ff7c3b558cd7507af47e8c90a9e90499f39e583 SHA512 ca63d68063cf48789d86dee3707b3ea7c5076fc1f636e17f408ad6f444303fb3a701af8d1e464d49af745e350272bffe8596853a52c01baa0bdb0b6b0c0bb303
EBUILD pytest-flakes-4.0.2-r1.ebuild 504 BLAKE2B 0f13610f981bb55bbf3bf835cc0a8e5cc10736b6db315b816285d177b8fb74daf28e9eefd10275ab22d0d8f005c7beadd5cfa68ba662e799f4fc6f73a7d0a1df SHA512 f0d6a0861840cc0a53c4f2b672ea05aa2b87d0c7563e100cd913d24c97ae0f0edda4afa0f9ecdf5b8f1c00530f0ed281847079fbc14a44fc4b8bf6773f32693b
+EBUILD pytest-flakes-4.0.3.ebuild 555 BLAKE2B 28f67239209928440a341b8d1171bccb85b60c47b46119af7f1320810598575b597ef85d6376a2f5c00d761178996d0d7dccab2848ee1ad567813d1bb5389069 SHA512 17decf5f132434923a17534af13c7597dcb6ee2e13803d8d916cf17c7ded539581c2f5a59a69ea9b2a7796899d7199067186d0aadbef6414bfea52d74193ef41
MISC metadata.xml 407 BLAKE2B 2e8f65fbdb38cc3c3ea57e44f7cf5b0494abcc0cdb79491d26fa46f06bbce1df59ce4bf3ee4f7d260e631d85bff888198255fcf1d4137a4c730e8a6f2abf7090 SHA512 e679e73ce16cb26f95d9181237d491e344e50d4cc45544d5cf41b9eeca1cb5b3dadc68620b3aee2a4c3710b475f329835fa206ad39ac1c5fa8a1685ac0dcceae
diff --git a/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch b/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
new file mode 100644
index 000000000000..35b4809c865b
--- /dev/null
+++ b/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
@@ -0,0 +1,17 @@
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Fri, 27 Aug 2021 08:23:16 +0300
+Subject: [PATCH] test_syntax_error: fix for python 3.10
+
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+--- a/test_flakes.py
++++ b/test_flakes.py
+@@ -20,7 +20,8 @@ for x in []
+ pass
+ """)
+ result = testdir.runpytest("--flakes", "--ignore", testdir.tmpdir)
+- assert "1: invalid syntax" in result.stdout.str()
++ assert ("1: invalid syntax" in result.stdout.str() or
++ "1: expected ':'" in result.stdout.str())
+ assert 'passed' not in result.stdout.str()
+
+
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
new file mode 100644
index 000000000000..d3a52d73420f
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/pytest-flakes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest