summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild')
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
new file mode 100644
index 000000000000..d3a52d73420f
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/pytest-flakes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest