summaryrefslogtreecommitdiff
path: root/dev-python/pyspf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/Manifest4
-rw-r--r--dev-python/pyspf/metadata.xml1
-rw-r--r--dev-python/pyspf/pyspf-2.0.14-r1.ebuild (renamed from dev-python/pyspf/pyspf-2.0.14.ebuild)14
3 files changed, 8 insertions, 11 deletions
diff --git a/dev-python/pyspf/Manifest b/dev-python/pyspf/Manifest
index bd4657446054..736a0fae065d 100644
--- a/dev-python/pyspf/Manifest
+++ b/dev-python/pyspf/Manifest
@@ -1,3 +1,3 @@
DIST pyspf-2.0.14.tar.gz 69446 BLAKE2B 95a3bf89ab85aad84dcbbe81ada7f19d23cc689893df1d1317c0e06eb1f6b6d21b1e805d68e7c0c84161d711b9c6067f115d78c8786ce384036f7d0c425269b9 SHA512 ca801a899a80c18cd2c6bb8c125817c29898189805040cce8d29ace7a5aa34b43b9d10545150a1f39abd7bc49cd8da4fe753a04ac9b911e7bb9d77473753eeee
-EBUILD pyspf-2.0.14.ebuild 833 BLAKE2B abf446735bbcf739a7a049e85e05845ae7ea62b4820516f3de98418735c7c2a854f3d8ef3d222d4c9d53c483e984335e65f86922eb68e1c35827db60e91f9bcc SHA512 f34357db0c997992159a60c1c23123b4834cb3a81199d19eb232b23414367beacece5100e9bf04fca30668fa09c31342e08e875bd97bf424c9e07f441ca1cbcd
-MISC metadata.xml 318 BLAKE2B 428f1f97b1e20927edbd26d3cb405e242e2bdc4c2cd301b9dd7999570b0ffb5af1c786a6cf596917d6d2694e29cf47c3809d3af97adb078064dc3562fe2690e1 SHA512 561cbdd0b14a8fb091ba9943987d93c8c1323a4b5f8f2b32f094284d683eec5562153a5a8ec77412a0806bac56c5667ec6e9e8d99e77bc2e45a5b7d517c8c483
+EBUILD pyspf-2.0.14-r1.ebuild 772 BLAKE2B b863072735c55902960330b41d7bbf2711523875ff46e0a5bf31ddd431003dfb257314ac8d54b5c3d2557fd9b46fa827937ef71b48a74eb486b0cc64f12244fa SHA512 1bfc91de9237316cf2ee7b8616a2ac61b2a7e10bb2439be22b55a35440dd9f40f714b94204a409db43cdd70b4d87da9bd7b8750463fa177d03597e09c31d1511
+MISC metadata.xml 343 BLAKE2B 8f762af399ad43eefeee1d17465045dff25ef1af58157b965f0d165485f6ef89b885d74edaaa364814d84e85bfa23aac92589f796c1d9260ed410d9a5ce0007e SHA512 25cc9e4b06ea1009b9492e418142d8f15679c46f536ca98e0cce89a6ea683730ddbdc720c808acac6cc4642db68a7208d646008f41d210c04170111dbfcccd24
diff --git a/dev-python/pyspf/metadata.xml b/dev-python/pyspf/metadata.xml
index d9d5ab63ea89..7c79d5d347ed 100644
--- a/dev-python/pyspf/metadata.xml
+++ b/dev-python/pyspf/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyspf</remote-id>
</upstream>
diff --git a/dev-python/pyspf/pyspf-2.0.14.ebuild b/dev-python/pyspf/pyspf-2.0.14-r1.ebuild
index 11776917e765..d48523dac805 100644
--- a/dev-python/pyspf/pyspf-2.0.14.ebuild
+++ b/dev-python/pyspf/pyspf-2.0.14-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="ipv6?"
DISTUTILS_USE_SETUPTOOLS=no
@@ -22,13 +22,10 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-python/authres[${PYTHON_USEDEP}]
- || (
- dev-python/pydns:3[${PYTHON_USEDEP}]
- dev-python/dnspython[${PYTHON_USEDEP}]
- )
+ dev-python/dnspython[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
test? (
${RDEPEND}
dev-python/pyyaml[${PYTHON_USEDEP}]
@@ -36,7 +33,6 @@ DEPEND="
"
python_test() {
- pushd test &> /dev/null || die
- "${PYTHON}" testspf.py || die
- popd &> /dev/null || die
+ cd test || die
+ "${EPYTHON}" testspf.py || die "Test fail with ${EPYTHON}"
}