summaryrefslogtreecommitdiff
path: root/dev-python/pyspf/pyspf-2.0.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyspf/pyspf-2.0.14-r1.ebuild')
-rw-r--r--dev-python/pyspf/pyspf-2.0.14-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyspf/pyspf-2.0.14-r1.ebuild b/dev-python/pyspf/pyspf-2.0.14-r1.ebuild
new file mode 100644
index 000000000000..d48523dac805
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.14-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="ipv6?"
+
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF)"
+HOMEPAGE="https://pypi.org/project/pyspf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ipv6 test"
+REQUIRED_USE="test? ( ipv6 )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/authres[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" testspf.py || die "Test fail with ${EPYTHON}"
+}