summaryrefslogtreecommitdiff
path: root/dev-python/pydantic/pydantic-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pydantic/pydantic-1.8.2.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-1.8.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pydantic/pydantic-1.8.2.ebuild b/dev-python/pydantic/pydantic-1.8.2.ebuild
index 26b8dccc514f..40c0a3ad124d 100644
--- a/dev-python/pydantic/pydantic-1.8.2.ebuild
+++ b/dev-python/pydantic/pydantic-1.8.2.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="Data parsing and validation using Python type hints"
@@ -36,6 +35,11 @@ src_prepare() {
}
python_test() {
- # TODO
- epytest --deselect tests/test_hypothesis_plugin.py
+ local ignore=(
+ # mypy results depend on version
+ tests/mypy/test_mypy.py
+ # TODO
+ tests/test_hypothesis_plugin.py
+ )
+ epytest ${ignore[@]/#/--ignore }
}