summaryrefslogtreecommitdiff
path: root/dev-python/pydantic/pydantic-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /dev-python/pydantic/pydantic-1.8.2.ebuild
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'dev-python/pydantic/pydantic-1.8.2.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-1.8.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/pydantic/pydantic-1.8.2.ebuild b/dev-python/pydantic/pydantic-1.8.2.ebuild
index 26b8dccc514f..40c0a3ad124d 100644
--- a/dev-python/pydantic/pydantic-1.8.2.ebuild
+++ b/dev-python/pydantic/pydantic-1.8.2.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="Data parsing and validation using Python type hints"
@@ -36,6 +35,11 @@ src_prepare() {
}
python_test() {
- # TODO
- epytest --deselect tests/test_hypothesis_plugin.py
+ local ignore=(
+ # mypy results depend on version
+ tests/mypy/test_mypy.py
+ # TODO
+ tests/test_hypothesis_plugin.py
+ )
+ epytest ${ignore[@]/#/--ignore }
}