summaryrefslogtreecommitdiff
path: root/dev-python/pycares
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest2
-rw-r--r--dev-python/pycares/pycares-4.4.0.ebuild6
2 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 16d392085e69..495a2e2165c8 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,3 +1,3 @@
DIST pycares-4.4.0.tar.gz 821630 BLAKE2B c2bddc54db9cd6ba92d7c4fb3809609a8a3526bab68e4cf48f0fee2e7473828f70ca696be11b904e9c3f9241de8b13568cd0317c8cb305a4aca7356f1b74cfb5 SHA512 db387f21975d015e0fcb01972ffb018476d51331a7a49bb4c0bf23ccfa13dff3f8b9c21d5f11da8ece3018debf36b1cddea032ef860353203cf38ab2b3d01e8a
-EBUILD pycares-4.4.0.ebuild 1080 BLAKE2B bc8acdd756bdc1badedf368c6deb339545eace88ecdcc49c78c97cb6fa85e9a5ee0f0cae70591256c20771592ff71f943c8d83342f07faa66ae54379b6fcff06 SHA512 9ae149cab304a0cd6ea86d994fb16976b81eb9c35dedaa31d0a375b87c76ac331dba975a0a2385606f2da35051e312e64fee639f3c60f10d5ce905dfb96678e2
+EBUILD pycares-4.4.0.ebuild 1219 BLAKE2B a2e3512ac31ac10efcbda0e457d3ab6c3b94edf87c419967c6bb0a6b0a74f370ab8f0118e13058859aff89e03d80abaefe43fabbc06265aba4e6155efff4c9ee SHA512 57db4399bb641095a5e163cf0edd2ff8310ba57fb3c6a8711d2a2181f34acda14c8cd48339a94b2f947cb93952149df84df93f60c5155aea7f38fca1c3cbf77a
MISC metadata.xml 444 BLAKE2B a68f545c6f704176b98ebb3665e2f56e4879016ea4ffa4f342954d568d6fe76ad67bcf9d521f694b8fc0f199bff50969eb646554fff4a78f8644ac44edda0cdf SHA512 fe893795f2031639d9fa27efcb8afbb5a3e0ac2eb2a05f0465391813d60fba07372633e40136ce38eb429bae95d1ae5dccecd0aba228537553524343133dd202
diff --git a/dev-python/pycares/pycares-4.4.0.ebuild b/dev-python/pycares/pycares-4.4.0.ebuild
index a9be17dffa99..6a60b1be40e8 100644
--- a/dev-python/pycares/pycares-4.4.0.ebuild
+++ b/dev-python/pycares/pycares-4.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="test"
# Tests fail with network-sandbox, since they try to resolve google.com
PROPERTIES="test_network"
@@ -48,6 +48,8 @@ EPYTEST_DESELECT=(
# regression due to Internet changing (probably)
# https://github.com/saghul/pycares/issues/187
tests/test_all.py::DNSTest::test_query_class_chaos
+ tests/test_all.py::DNSTest::test_idna_encoding_query_a
+ tests/test_all.py::DNSTest::test_query_txt_chunked
# TODO
tests/test_all.py::DNSTest::test_custom_resolvconf
)