summaryrefslogtreecommitdiff
path: root/dev-python/pycares/pycares-4.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pycares/pycares-4.4.0.ebuild')
-rw-r--r--dev-python/pycares/pycares-4.4.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pycares/pycares-4.4.0.ebuild b/dev-python/pycares/pycares-4.4.0.ebuild
index a9be17dffa99..6a60b1be40e8 100644
--- a/dev-python/pycares/pycares-4.4.0.ebuild
+++ b/dev-python/pycares/pycares-4.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="test"
# Tests fail with network-sandbox, since they try to resolve google.com
PROPERTIES="test_network"
@@ -48,6 +48,8 @@ EPYTEST_DESELECT=(
# regression due to Internet changing (probably)
# https://github.com/saghul/pycares/issues/187
tests/test_all.py::DNSTest::test_query_class_chaos
+ tests/test_all.py::DNSTest::test_idna_encoding_query_a
+ tests/test_all.py::DNSTest::test_query_txt_chunked
# TODO
tests/test_all.py::DNSTest::test_custom_resolvconf
)