summaryrefslogtreecommitdiff
path: root/dev-python/lazy-loader/lazy-loader-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lazy-loader/lazy-loader-0.4.ebuild')
-rw-r--r--dev-python/lazy-loader/lazy-loader-0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/lazy-loader/lazy-loader-0.4.ebuild b/dev-python/lazy-loader/lazy-loader-0.4.ebuild
new file mode 100644
index 000000000000..1f89c455db85
--- /dev/null
+++ b/dev-python/lazy-loader/lazy-loader-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Populate library namespace without incurring immediate import costs"
+HOMEPAGE="
+ https://github.com/scientific-python/lazy_loader
+ https://pypi.org/project/lazy-loader/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+"