summaryrefslogtreecommitdiff
path: root/dev-python/lazy-loader/lazy-loader-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-python/lazy-loader/lazy-loader-0.4.ebuild
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-python/lazy-loader/lazy-loader-0.4.ebuild')
-rw-r--r--dev-python/lazy-loader/lazy-loader-0.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/lazy-loader/lazy-loader-0.4.ebuild b/dev-python/lazy-loader/lazy-loader-0.4.ebuild
new file mode 100644
index 000000000000..1f89c455db85
--- /dev/null
+++ b/dev-python/lazy-loader/lazy-loader-0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Populate library namespace without incurring immediate import costs"
+HOMEPAGE="
+ https://github.com/scientific-python/lazy_loader
+ https://pypi.org/project/lazy-loader/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+"