summaryrefslogtreecommitdiff
path: root/dev-python/gast/gast-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gast/gast-0.5.2.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.2.ebuild b/dev-python/gast/gast-0.5.2.ebuild
new file mode 100644
index 000000000000..f25219967d31
--- /dev/null
+++ b/dev-python/gast/gast-0.5.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/astunparse[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest