summaryrefslogtreecommitdiff
path: root/dev-python/gast/gast-0.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/gast/gast-0.5.2.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/gast/gast-0.5.2.ebuild')
-rw-r--r--dev-python/gast/gast-0.5.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/gast/gast-0.5.2.ebuild b/dev-python/gast/gast-0.5.2.ebuild
new file mode 100644
index 000000000000..f25219967d31
--- /dev/null
+++ b/dev-python/gast/gast-0.5.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A generic AST to represent Python2 and Python3's Abstract Syntax Tree (AST)"
+HOMEPAGE="https://pypi.org/project/gast/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/astunparse[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest