summaryrefslogtreecommitdiff
path: root/dev-python/flask-script
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-script')
-rw-r--r--dev-python/flask-script/Manifest6
-rw-r--r--dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch39
-rw-r--r--dev-python/flask-script/flask-script-2.0.6.ebuild23
-rw-r--r--dev-python/flask-script/metadata.xml1
4 files changed, 22 insertions, 47 deletions
diff --git a/dev-python/flask-script/Manifest b/dev-python/flask-script/Manifest
index f69117bd5509..3900cea9775b 100644
--- a/dev-python/flask-script/Manifest
+++ b/dev-python/flask-script/Manifest
@@ -1,4 +1,4 @@
-AUX flask-script-2.0.6-flask_script-everywhere.patch 1792 BLAKE2B d3d674ad325f04b9338fd50850850173a3bb8c89de64702a8c6f5e78b6ad3945dadff4ffeb24bfce20b8d7e032338ae58695f9ce6eaa56f130286197915c3110 SHA512 83acf9eca3b2ee87222e6d307367f1aa789c8c89d6d4cba8dc93ff69a6149bf05e958baa4f9d7e71d3878e90ddce54a2d89b258024bf3bafc39de86814e4ad4a
+AUX flask-script-2.0.6-flask_script-everywhere.patch 1368 BLAKE2B 0d387cce36afdfb67bb91661df23884a7782d26ec5979121664afc84f48e780b7d1498b6233779980d3fd51f672a7fd5a6e097bef946a8599e189863d2be1ad3 SHA512 9694070e86a47f405d7bdd3e4c37df56e2fcbc86f64adea07d10c4e5be6856a6631eac5af43cd372bf13475b8dc9ab57f263f10dbb62621365fdf17d4e4efb64
DIST Flask-Script-2.0.6.tar.gz 43146 BLAKE2B 146a65fce432063e67e5b6221a0c2437f2a8df1e2b72a5e14fb382dc51ef3f0755e4d8a0a67831c6c2c61d07acc332e8c87b7c9df3443a9f22aa2eeb580c4086 SHA512 03c51213be8e2b86f1f4450565cf4d7e3d9d7257ac017bd53830be57620d581f43bcfe959ef7b621af722c688c56495229aad3dd9654c8a8a5905db0105275fc
-EBUILD flask-script-2.0.6.ebuild 1106 BLAKE2B 90064f97ebda927f16b6531d14662f1518efc9f58cd4e04f16689ccd0904081b5d474160cc08d17aa1471cabe3506cb8bd490dd547ef7eb33683e93a46dbfa72 SHA512 7a5bb1464579da364f4132a47f43c47061d01cef403dfd7694e0e6bc816dc5c4ea385456b64c7471a79966919755b14c6b84289feddb6c68b4ba6009efbae274
-MISC metadata.xml 339 BLAKE2B 0a4f6acd12f3f742a5e5f140aba858a35b563f1b8050813457cfe9be240403bedd42c9672cfea69fedf7f00ab5166ddace90ce5e93561bc5f3fa33a7ece68595 SHA512 227621e6eae61c89709dbca856fc11be6367cfdafae280796d71b3962f6fef03e3eef4e3e57c7dea411f17233eed65077e37409b12336241aa64bae8ce084a66
+EBUILD flask-script-2.0.6.ebuild 762 BLAKE2B ef446d49b8e5e722dbf25da876b7aaba6499d58196f85efe6fabeb137c2a6a41c994248941d67ea4a20c8f7e5870f5d6d7a3b214c8ed3dbac5615a0e2be3a8de SHA512 f99022059ddb2af8cc16443b195295571826f05bfe63369b44d56e8127f0367c131fe53d3bc49a098d587d154d092bd6331f4c2c1daa4d1cb24c8de8138f7422
+MISC metadata.xml 399 BLAKE2B 86e06a282b8aec88aed0414253e9f93fb687806eff88dee296933e5956d466a6dfa2682143cdd1bdbb0b36ae45615492166648e51de4c5be3c9ebdc65ddb6e97 SHA512 046fbd63a3f45d8d26fbf8991111dd2e93c17e72409a76fd896147c534bc6cedd03a3405f7f0ae682168bfbf4db62743e88bb805419b7f687f2540155dee3f73
diff --git a/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch b/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
index b10b2f0a2283..04259c89a420 100644
--- a/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
+++ b/dev-python/flask-script/files/flask-script-2.0.6-flask_script-everywhere.patch
@@ -1,16 +1,7 @@
-From fcf894b6e4d0ad17489480b722c870aaea600db1 Mon Sep 17 00:00:00 2001
From: anthraxx <levente@leventepolyak.net>
Date: Wed, 6 Sep 2017 12:03:22 +0200
Subject: [PATCH] using flask_script everywhere instead of flask.ext.script
----
- docs/index.rst | 2 +-
- examples/manage.py | 4 ++--
- tests.py | 4 ++--
- 3 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/docs/index.rst b/docs/index.rst
-index 775ffca..9266d4b 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -577,7 +577,7 @@ Then the user can register the sub-manager to their primary Manager (within mana
@@ -22,23 +13,6 @@ index 775ffca..9266d4b 100644
manager.add_command("database", database_manager)
The commands will then be available::
-#diff --git a/examples/manage.py b/examples/manage.py
-#index 5c0dc21..8129555 100755
-#--- a/examples/manage.py
-#+++ b/examples/manage.py
-#@@ -4,8 +4,8 @@
-# import pprint
-#
-# from flask import Flask, current_app
-#-from flask.ext.script import Manager, prompt_choices, Server
-#-from flask.ext.script.commands import ShowUrls, Clean
-#+from flask_script import Manager, prompt_choices, Server
-#+from flask_script.commands import ShowUrls, Clean
-#
-#
-# def create_app(config=None):
-diff --git a/tests.py b/tests.py
-index 93d0071..24f3f15 100644
--- a/tests.py
+++ b/tests.py
@@ -5,8 +5,8 @@
@@ -52,3 +26,16 @@ index 93d0071..24f3f15 100644
from pytest import raises
+--- a/flask_script/__init__.py
++++ b/flask_script/__init__.py
+@@ -12,9 +12,8 @@ from collections import OrderedDict
+ import argparse
+
+ from flask import Flask
+-from flask._compat import text_type
+
+-from ._compat import iteritems
++from ._compat import iteritems, text_type
+ from .commands import Group, Option, Command, Server, Shell
+ from .cli import prompt, prompt_pass, prompt_bool, prompt_choices
+
diff --git a/dev-python/flask-script/flask-script-2.0.6.ebuild b/dev-python/flask-script/flask-script-2.0.6.ebuild
index cd84dc29df06..1932eee2f304 100644
--- a/dev-python/flask-script/flask-script-2.0.6.ebuild
+++ b/dev-python/flask-script/flask-script-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="Flask-Script"
@@ -14,32 +14,19 @@ HOMEPAGE="https://flask-script.readthedocs.io/en/latest/
https://flask-script.readthedocs.io/en/latest/
https://pypi.org/project/Flask-Script/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${P}-flask_script-everywhere.patch" )
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
python_test() {
- py.test tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ epytest tests.py
}
diff --git a/dev-python/flask-script/metadata.xml b/dev-python/flask-script/metadata.xml
index 246d0bc31b61..fa530d0dfb08 100644
--- a/dev-python/flask-script/metadata.xml
+++ b/dev-python/flask-script/metadata.xml
@@ -8,5 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">Flask-Script</remote-id>
+ <remote-id type="github">smurfix/flask-script</remote-id>
</upstream>
</pkgmetadata>