summaryrefslogtreecommitdiff
path: root/dev-python/flask-script/flask-script-2.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-script/flask-script-2.0.6.ebuild')
-rw-r--r--dev-python/flask-script/flask-script-2.0.6.ebuild23
1 files changed, 5 insertions, 18 deletions
diff --git a/dev-python/flask-script/flask-script-2.0.6.ebuild b/dev-python/flask-script/flask-script-2.0.6.ebuild
index cd84dc29df06..1932eee2f304 100644
--- a/dev-python/flask-script/flask-script-2.0.6.ebuild
+++ b/dev-python/flask-script/flask-script-2.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="Flask-Script"
@@ -14,32 +14,19 @@ HOMEPAGE="https://flask-script.readthedocs.io/en/latest/
https://flask-script.readthedocs.io/en/latest/
https://pypi.org/project/Flask-Script/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${P}-flask_script-everywhere.patch" )
-python_compile_all() {
- use doc && emake -C docs html
-}
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
python_test() {
- py.test tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ epytest tests.py
}