summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli_helpers')
-rw-r--r--dev-python/cli_helpers/Manifest4
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.2.0.ebuild24
-rw-r--r--dev-python/cli_helpers/cli_helpers-9999.ebuild5
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-python/cli_helpers/Manifest b/dev-python/cli_helpers/Manifest
index c7f326a6e09c..9496a50c5ac5 100644
--- a/dev-python/cli_helpers/Manifest
+++ b/dev-python/cli_helpers/Manifest
@@ -1,4 +1,6 @@
DIST cli_helpers-2.1.0.tar.gz 32967 BLAKE2B c2ee2a92dce4185f656415d6079196953c5e9dccf9de4e29d9de61bf72b041a6225ffe4afa866b0f78abcd5d0809ec739db489aee21e440575b7e2a6e09b916a SHA512 75c6b24ae1ed05cbdfddfc30c5e43aeb7129f5fa319d485e19be098691762ad681c4874449b2f339f833424a970965b5a28a3b66814cb556ea8ad6293740fdbe
+DIST cli_helpers-2.2.0.tar.gz 34018 BLAKE2B c7dfe8b87db6312557b4ac87aa4eda77b94f12789fcd4a9e686cada47bd41601f5c357a77de4a1c6d550b2ea110b682da0a04edb312d26ecf281e6d323369462 SHA512 26d78227999e8bb37f58529ce29bbed1bc8d51c80f81127552fb1d1f880c476abdd43ca628c591ba50c0316b35d1df0541906bf902a7549f459da0e1200c8479
EBUILD cli_helpers-2.1.0.ebuild 659 BLAKE2B 1a0e3145b9979a5c9e0417f41b67ff5b185536ac0520f57671d5fb9cf0b858b362a0f5d6d3f7e0e8e8e2e3d00bdd66ecb1849adccc4f92c5db259c72ff93c98d SHA512 cb1b52ef15cfbb4e908c0cb7a1d0881a6f71232207a8eeae0f074b5d409bc9611d463fb0dc3dad64ba5fcefa8d8ad70b580095b8bb8f430a93f58a7119855069
-EBUILD cli_helpers-9999.ebuild 641 BLAKE2B f07a3f78ada7409a32b32c74b6892192a90fad594d958bd6fb4b48682e1463731780f016cf61b2113d6519b63ce9e4dbf2262c253f39a9ebffea61b15553a0c1 SHA512 fb46213585db5f4dc14170b4eddff214518dc749ad2e53860d999bea860e0ebca8478d948cbcd47b47961acc8d6f244e3992546e820250b1793b044ba4bc7c68
+EBUILD cli_helpers-2.2.0.ebuild 608 BLAKE2B 2033a3fd8610ce23f022f7c4d5ab073ff71ebe0a488e0cbf0fb4cf4340e151dc0a77ee716373308cc9b1ac0426c77eacc899f294fb4bc4a092f5c40e36fca330 SHA512 9aac9b1721a48da0031d344488ef04e5cd7c9a4d5baeea5b3d4927e438a8aca7af9ef6a96f583397d644be54847e503660746aaa267464a810532eb6d118b29c
+EBUILD cli_helpers-9999.ebuild 588 BLAKE2B abf6f583c85379da640a8b9a2075d2f59f1bd0134f2656d2e3be7b3ae9a63efc36df1b94f4e60af2d00fbe4822430c9519660049496ae1907e43d7ad96711f16 SHA512 1b8ffba1750845b4f236d50443d1dd9357a8edd8898c81c4563317761809faa111fbfc81922c53757906c6d43844f4da205bf116821842554020df807dec3a5d
MISC metadata.xml 456 BLAKE2B 3c7bef25195fc639bb4bcbf6edf7236e18c8b338e9327673da6b4aca9778363115ff3f271015d01b98fc4728028b751ae9d55f85f3375adff20862f6b6a9706d SHA512 c3d592c696302e6e11accf1b50853e6f114c5de063ceb02d22eb23d3e8af338a0222d9615ab689825f483aee1156acb939ccfb01c1fe768571ddf137a28e3e95
diff --git a/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
new file mode 100644
index 000000000000..a558d553a0bc
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cli_helpers/cli_helpers-9999.ebuild b/dev-python/cli_helpers/cli_helpers-9999.ebuild
index f36ceb139659..58df205d42ff 100644
--- a/dev-python/cli_helpers/cli_helpers-9999.ebuild
+++ b/dev-python/cli_helpers/cli_helpers-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
EGIT_REPO_URI="https://github.com/dbcli/${PN}.git"
inherit distutils-r1 git-r3
@@ -19,7 +19,6 @@ RDEPEND="
>=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
>=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
>=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
- >=dev-python/terminaltables-3.0.0[${PYTHON_USEDEP}]
dev-python/wcwidth[${PYTHON_USEDEP}]
"