summaryrefslogtreecommitdiff
path: root/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-2.2.0.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
new file mode 100644
index 000000000000..a558d553a0bc
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest