summaryrefslogtreecommitdiff
path: root/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/babelfish/babelfish-0.6.0-r1.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-0.6.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/babelfish/babelfish-0.6.0-r1.ebuild b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..69cb0c404508
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="
+ https://github.com/Diaoul/babelfish/
+ https://pypi.org/project/babelfish/"
+SRC_URI="
+ https://github.com/Diaoul/babelfish/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest