summaryrefslogtreecommitdiff
path: root/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /dev-python/babelfish/babelfish-0.6.0-r1.ebuild
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'dev-python/babelfish/babelfish-0.6.0-r1.ebuild')
-rw-r--r--dev-python/babelfish/babelfish-0.6.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/babelfish/babelfish-0.6.0-r1.ebuild b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..69cb0c404508
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.6.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="
+ https://github.com/Diaoul/babelfish/
+ https://pypi.org/project/babelfish/"
+SRC_URI="
+ https://github.com/Diaoul/babelfish/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-20[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest