summaryrefslogtreecommitdiff
path: root/dev-python/ansible-pygments
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansible-pygments')
-rw-r--r--dev-python/ansible-pygments/Manifest3
-rw-r--r--dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild21
-rw-r--r--dev-python/ansible-pygments/metadata.xml13
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ansible-pygments/Manifest b/dev-python/ansible-pygments/Manifest
new file mode 100644
index 000000000000..5aa7329b356c
--- /dev/null
+++ b/dev-python/ansible-pygments/Manifest
@@ -0,0 +1,3 @@
+DIST ansible-pygments-0.1.0.tar.gz 8046 BLAKE2B a6b9873dc8494af77a8c71de45f23dbd14419f3abb98d577631d51be9fe48cc88f5bec2f77707fd376369e325538800a47ae014a13f85022f805466a2e590316 SHA512 370a28e984f1c19c78b3047c5506847d625ad46458067804fcc7cc850d01cb77f837fbc80071fc9ff0e9df31805e48477a3026ce28389de8de368d35bd9d9428
+EBUILD ansible-pygments-0.1.0.ebuild 507 BLAKE2B ecf2f2eeb03f50201df68932d25329d03243dd8cba4172fa017c5a7e1c8864036326e2b31d85cec34cd05577c7292f8caf7ac98fa226059b47b4895828561cd6 SHA512 68b1ee041430d0cc93143015068271b42e725d7c1060895d54f29efabfca1192d6374fbc68f95d3c0977a25b1518419a20b951c8c229f978d1ee15f94eb0092c
+MISC metadata.xml 422 BLAKE2B b96f233ce9ad02a10fa5280beac77360d4f9f72b6f023bd5c4b3568a1873805030e2e8afd622d332a34897ea76f4ce1e6534079a0a37e090905ffd46799277d4 SHA512 8906d77394e5f47d64142a2a03baf84d2dfe404b91077aee0988550593dc0a3fbd59e8c6a943fe7656bbbcfc9ecb830b420919c3854cca9b81b76f151623ec46
diff --git a/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild b/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild
new file mode 100644
index 000000000000..d1a3cf442138
--- /dev/null
+++ b/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+DESCRIPTION="Pygments lexer and style Ansible snippets"
+HOMEPAGE="https://github.com/ansible-community/ansible-pygments"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansible-pygments/metadata.xml b/dev-python/ansible-pygments/metadata.xml
new file mode 100644
index 000000000000..a06620b5aa8a
--- /dev/null
+++ b/dev-python/ansible-pygments/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">ansible-community/ansible-pygments</remote-id>
+ <remote-id type="pypi">ansible-pygments</remote-id>
+ </upstream>
+</pkgmetadata>