summaryrefslogtreecommitdiff
path: root/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild')
-rw-r--r--dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild b/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild
new file mode 100644
index 000000000000..d1a3cf442138
--- /dev/null
+++ b/dev-python/ansible-pygments/ansible-pygments-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS="pyproject.toml"
+
+inherit distutils-r1
+
+DESCRIPTION="Pygments lexer and style Ansible snippets"
+HOMEPAGE="https://github.com/ansible-community/ansible-pygments"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest