summaryrefslogtreecommitdiff
path: root/dev-python/aiodns
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest3
-rw-r--r--dev-python/aiodns/aiodns-3.0.0.ebuild7
-rw-r--r--dev-python/aiodns/files/aiodns-3.0.0-py3.10-tests.patch24
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index 84a0fd772566..545eac9e98b4 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1,3 +1,4 @@
+AUX aiodns-3.0.0-py3.10-tests.patch 757 BLAKE2B 1b5040841b3ced3b83b330e0033f54ee6ee97a8d025f22d87674f5fca9858e48febbf25c6b3441ba5b27ef9cb15f841e65f25ed999b9f536559ec50e1f010bbc SHA512 85219c885ee70871fb43f53e2ec52c164b08b63e120ee5ca5bc4531ea71155b6d81f5a813f056eabf7f4da2b425b12df6b5649cc7a9ba98d0ca9473043ee1829
DIST aiodns-3.0.0.tar.gz 6743 BLAKE2B 2a3c61156069fa598df58191b35383da3e054396cdeb1bc8916cc0414bb6efc89d45789883a5b4f33e3a08a6ee544356b02d6c697c096deae3398f0ff4d3c316 SHA512 8c1016f3b0cb461e70e9a55034f9ad3b3db705a845bf20bb6503c7a5d592b4c5d2e8ddc60b375c5fafdc559dc4566736f4c93f26710be2dcbd181284ef039825
-EBUILD aiodns-3.0.0.ebuild 610 BLAKE2B 781e29313aaf735487da828ceb6abf3cebc5593285049d1f278f464451a3f9fe914f1dd467ef8819ea8619499b530ceedd5eabf9a83af4221f05f78acba66d13 SHA512 c1baf4dd27ef0f09542efa459683510b80cbe104b8c269382697aa2caaf914bc5780ccf8f7f840b917d412fd8941e5e98b69afe8f3756628d73a15425e05b4df
+EBUILD aiodns-3.0.0.ebuild 747 BLAKE2B f20118109d74b1a03efbcdce28e2da6ddad9b371ef58ee13e3adc2b881cb71c0da19aa7410494171750f56b57812b19e5f9f07743a1e1c7202ee1201ed577131 SHA512 e38c11463a2bcf98ffe27044346c7ed5d921bad1693e3ec530902c08014b5ed1d6e136969ee46ab497c723d4e490a2a0bbc489b89003699175b2c0c3079d9f4f
MISC metadata.xml 340 BLAKE2B e607777274ea754605542b7ade5ba3d118ff366ae3bc57f586031450dd54e43189e0e1b3fd8305e351380bda96289e0cd95e074fdebaa7816da757329203775f SHA512 b77ba4eb56072b4801832400361bcc80e73c2f0f1507e9abfd8c9beaa255594554b4a2555e3304307af6c515bea097311c70f515f875a7a98cc197e5cf538ce3
diff --git a/dev-python/aiodns/aiodns-3.0.0.ebuild b/dev-python/aiodns/aiodns-3.0.0.ebuild
index 59ee54a21755..622a6671b886 100644
--- a/dev-python/aiodns/aiodns-3.0.0.ebuild
+++ b/dev-python/aiodns/aiodns-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -21,6 +21,11 @@ RESTRICT="test"
RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=(
+ # https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
+ "${FILESDIR}/${P}-py3.10-tests.patch"
+)
+
python_test() {
"${EPYTHON}" tests.py -v || die
}
diff --git a/dev-python/aiodns/files/aiodns-3.0.0-py3.10-tests.patch b/dev-python/aiodns/files/aiodns-3.0.0-py3.10-tests.patch
new file mode 100644
index 000000000000..19062f1c8861
--- /dev/null
+++ b/dev-python/aiodns/files/aiodns-3.0.0-py3.10-tests.patch
@@ -0,0 +1,24 @@
+From 146286601fe80eb4ede8126769e79b5d5e63f64e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 15 May 2021 10:03:01 +0200
+Subject: [PATCH] Remove loop= param from asyncio.sleep() to fix tests on
+ Python 3.10
+
+Fixes #95
+---
+ tests.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests.py b/tests.py
+index 7b2279f..fc0e2b9 100755
+--- a/tests.py
++++ b/tests.py
+@@ -116,7 +116,7 @@ def test_future_cancel(self):
+ f = self.resolver.query('google.com', 'A')
+ f.cancel()
+ async def coro():
+- await asyncio.sleep(0.1, loop=self.loop)
++ await asyncio.sleep(0.1)
+ await f
+ try:
+ self.loop.run_until_complete(coro())