summaryrefslogtreecommitdiff
path: root/dev-python/aiodns/aiodns-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiodns/aiodns-3.0.0.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-3.0.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/aiodns/aiodns-3.0.0.ebuild b/dev-python/aiodns/aiodns-3.0.0.ebuild
index 59ee54a21755..622a6671b886 100644
--- a/dev-python/aiodns/aiodns-3.0.0.ebuild
+++ b/dev-python/aiodns/aiodns-3.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -21,6 +21,11 @@ RESTRICT="test"
RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
+PATCHES=(
+ # https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
+ "${FILESDIR}/${P}-py3.10-tests.patch"
+)
+
python_test() {
"${EPYTHON}" tests.py -v || die
}