summaryrefslogtreecommitdiff
path: root/dev-python/agate-sql/agate-sql-0.5.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/agate-sql/agate-sql-0.5.7.ebuild')
-rw-r--r--dev-python/agate-sql/agate-sql-0.5.7.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/agate-sql/agate-sql-0.5.7.ebuild b/dev-python/agate-sql/agate-sql-0.5.7.ebuild
index e58ff6efb206..a5527246e03d 100644
--- a/dev-python/agate-sql/agate-sql-0.5.7.ebuild
+++ b/dev-python/agate-sql/agate-sql-0.5.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Adds SQL read/write support to agate."
@@ -42,16 +42,9 @@ python_prepare_all() {
}
python_test() {
- local pytest_args test_name xfails
-
- xfails=(
+ local deselect=(
tests/test_agatesql.py::TestSQL::test_to_sql_create_statement_with_dialects
tests/test_agatesql.py::TestSQL::test_to_sql_create_statement_with_schema
)
-
- for test_name in "${xfails[@]}"; do
- pytest_args+=(--deselect "${test_name}")
- done
-
- epytest "${pytest_args[@]}"
+ epytest ${deselect[@]/#/--deselect }
}