summaryrefslogtreecommitdiff
path: root/dev-python/agate-sql/agate-sql-0.5.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /dev-python/agate-sql/agate-sql-0.5.7.ebuild
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'dev-python/agate-sql/agate-sql-0.5.7.ebuild')
-rw-r--r--dev-python/agate-sql/agate-sql-0.5.7.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/agate-sql/agate-sql-0.5.7.ebuild b/dev-python/agate-sql/agate-sql-0.5.7.ebuild
index e58ff6efb206..a5527246e03d 100644
--- a/dev-python/agate-sql/agate-sql-0.5.7.ebuild
+++ b/dev-python/agate-sql/agate-sql-0.5.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Adds SQL read/write support to agate."
@@ -42,16 +42,9 @@ python_prepare_all() {
}
python_test() {
- local pytest_args test_name xfails
-
- xfails=(
+ local deselect=(
tests/test_agatesql.py::TestSQL::test_to_sql_create_statement_with_dialects
tests/test_agatesql.py::TestSQL::test_to_sql_create_statement_with_schema
)
-
- for test_name in "${xfails[@]}"; do
- pytest_args+=(--deselect "${test_name}")
- done
-
- epytest "${pytest_args[@]}"
+ epytest ${deselect[@]/#/--deselect }
}