summaryrefslogtreecommitdiff
path: root/dev-perl/Sys-Statistics-Linux
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Sys-Statistics-Linux')
-rw-r--r--dev-perl/Sys-Statistics-Linux/Manifest2
-rw-r--r--dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r2.ebuild (renamed from dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild)28
2 files changed, 11 insertions, 19 deletions
diff --git a/dev-perl/Sys-Statistics-Linux/Manifest b/dev-perl/Sys-Statistics-Linux/Manifest
index d36c62369ba3..daec3135d016 100644
--- a/dev-perl/Sys-Statistics-Linux/Manifest
+++ b/dev-perl/Sys-Statistics-Linux/Manifest
@@ -1,3 +1,3 @@
DIST Sys-Statistics-Linux-0.66.tar.gz 49987 BLAKE2B 1b0776dfc5693802366429b1c5f34bd2c19e270b0e2e4f606c58033eae9e112e7dd7e841d0bfb5e1e21e151cb28801fb5b40eb2975ebee1ee1b08be9c7bd03f1 SHA512 0387e7746d923860e5d9362f3259c19fc2e173cf6199aae11238a9bc0b588afe05026a876592845e0ac12f445cfb2c38ff7646fe9beed5807548179c7b2754b4
-EBUILD Sys-Statistics-Linux-0.660.0-r1.ebuild 624 BLAKE2B be51ddc86b471bf9b243f8611ff767469139524cace02e219b0577be8bfe73697faf4966d78467dcc1cd7984f32c26b4e4b31c25b78fbab4ce7a311bfce00beb SHA512 16691caaa8237ef7efd0f4e08e818bc3d10eb931c9a697401bb337cc3ff1c69c1ffd0fb2e8ad00689b25ceeef811061fdad7f36ca0c6643cceaa283d0bd51250
+EBUILD Sys-Statistics-Linux-0.660.0-r2.ebuild 473 BLAKE2B 04f3214cf48df0e5fd23861c38bd86316212454484092d80b6535222bf4fd6970ff8e93fc9d423d2d874ee79c5dc84c2651c8250cd9ae2b13c8be3fb40f9e8be SHA512 2ca7c72d4ac5b7f85d946789c37c898993cbe60e814860bfe9871538e0e2628fb96c830188cdfe10e0a6982b198555e813138f9f411131cbd1cfc1b15d0ed4b6
MISC metadata.xml 1448 BLAKE2B 11626695d31ebfd99d7a603c82d0d1de5c434a2e9aeac7ee3feb26af15ad30f94048765c03a018ddd41ebd1905042c283b1431fc7557eaddc1f36e44497ebd56 SHA512 9b7c4db52c8f5e8a2c793be13898c62918ec12657ef3b90581e9af5723625b88e8619b56e0af468ffc119578277001237647a5de96686e233dcad774831e3330
diff --git a/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild b/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r2.ebuild
index a2a5b2e6d2b8..b3766a081c34 100644
--- a/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r1.ebuild
+++ b/dev-perl/Sys-Statistics-Linux/Sys-Statistics-Linux-0.660.0-r2.ebuild
@@ -1,35 +1,27 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-MODULE_AUTHOR=BLOONIX
-MODULE_VERSION=0.66
+DIST_AUTHOR=BLOONIX
+DIST_VERSION=0.66
+DIST_EXAMPLES=( 'examples/*' )
inherit perl-module
DESCRIPTION="Collect linux system statistics"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-perl/YAML-Syck"
-DEPEND="
+RDEPEND="
+ dev-perl/YAML-Syck
+"
+BDEPEND="
dev-perl/Module-Build
test? (
virtual/perl-Test-Simple
- )"
-
-SRC_TEST="do"
-
-src_install() {
- perl-module_src_install
-
- docompress -x /usr/share/doc/${PF}/examples
- docinto examples
- dodoc -r examples/.
-}
+ )
+"
src_test() {
perl_rm_files t/001-pod.t t/002-pod-coverage.t