summaryrefslogtreecommitdiff
path: root/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild')
-rw-r--r--dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild b/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
new file mode 100644
index 000000000000..990c620701d8
--- /dev/null
+++ b/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.102084
+inherit perl-module
+
+DESCRIPTION="build sprintf-like functions of your own"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Params-Util
+ dev-perl/Sub-Exporter
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+
+PERL_RM_FILES=(
+ "bench.pl" # https://github.com/rjbs/String-Formatter/issues/2
+)