summaryrefslogtreecommitdiff
path: root/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild')
-rw-r--r--dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild b/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
new file mode 100644
index 000000000000..990c620701d8
--- /dev/null
+++ b/dev-perl/String-Formatter/String-Formatter-0.102.84-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=0.102084
+inherit perl-module
+
+DESCRIPTION="build sprintf-like functions of your own"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Params-Util
+ dev-perl/Sub-Exporter
+"
+BDEPEND="
+ ${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+
+PERL_RM_FILES=(
+ "bench.pl" # https://github.com/rjbs/String-Formatter/issues/2
+)