summaryrefslogtreecommitdiff
path: root/dev-perl/Gentoo-App-Pram
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Gentoo-App-Pram')
-rw-r--r--dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild38
-rw-r--r--dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0.ebuild4
-rw-r--r--dev-perl/Gentoo-App-Pram/Manifest3
3 files changed, 42 insertions, 3 deletions
diff --git a/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..5d83f1ee0e10
--- /dev/null
+++ b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MONSIEURP
+DIST_VERSION=0.200000
+
+inherit perl-module
+
+DESCRIPTION="Tool to merge PRs from the Gentoo Github repository"
+HOMEPAGE="https://github.com/monsieurp/Gentoo-App-Pram"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/perl-Encode
+ dev-perl/File-Which
+ dev-perl/Net-SSLeay
+ dev-perl/IO-Socket-SSL
+ virtual/perl-File-Temp
+ virtual/perl-HTTP-Tiny
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ !app-portage/pram"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ )"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build-Tiny"
diff --git a/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0.ebuild b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0.ebuild
index 1034893687f6..d9b1c167fee4 100644
--- a/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0.ebuild
+++ b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ DIST_VERSION=0.200000
inherit perl-module
-DESCRIPTION="Official tool to merge PRs from the Gentoo Github repository"
+DESCRIPTION="Tool to merge PRs from the Gentoo Github repository"
HOMEPAGE="https://github.com/monsieurp/Gentoo-App-Pram"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
diff --git a/dev-perl/Gentoo-App-Pram/Manifest b/dev-perl/Gentoo-App-Pram/Manifest
index d5d02f564561..f94a85325619 100644
--- a/dev-perl/Gentoo-App-Pram/Manifest
+++ b/dev-perl/Gentoo-App-Pram/Manifest
@@ -1,3 +1,4 @@
DIST Gentoo-App-Pram-0.200000.tar.gz 13061 BLAKE2B 783c50954f3936bc2dbae4d0db0baf52d5a7ecbdd576ada75e1c183816432a09059e1712b337fd1b7ae79dd774242ac684a0e8bea26a90424458ed35de523209 SHA512 90f82400de8ff6afc56ee6c66394188bb0b9aedd584879588f8ba5555b6ffad60de109e91a2d223593e2c78b21754957110718a7fba0cf76050c79cc823d505a
-EBUILD Gentoo-App-Pram-0.200.0.ebuild 708 BLAKE2B 011d20340224c7c3c19ae4f321518fa68901ee2ec769592aaaaf7e7712468c047df95072c39fb94b9b2af00be2a110a762d41b36485dfd00ca8d19abcd03a7ce SHA512 f544fefc9afb88282d8a54b07ae0c30438bcc0d94805f55e788a6e90868463d358dd1afca4e6cd8c93f0788722cf1c4b5804fe1e9c119ce7035c2308faac72cf
+EBUILD Gentoo-App-Pram-0.200.0-r1.ebuild 725 BLAKE2B 4e819b3ac021af5b046a8cdac7c65ed24951117a37e49a4ba16ed9455a250c2c61ba0e97167ea248e24e3fe4d4e0353bf761f315069b4e4d7a7a75a1ccb1570a SHA512 782e65cbde0a9c60543520431722f085ca5f9c3f9bcc7b157c01f3e5ccc5caf1f0f9a789f5a0b999c4a0d7ec20ce2789ab8ab36b0f07ce56cc79c49e04d3d1c1
+EBUILD Gentoo-App-Pram-0.200.0.ebuild 699 BLAKE2B 1092b78942d54afc75db227aab8879bfd32de8cf737dfbc6f1ead7531bb4d0330d005ac351292eb71d07b741adaf2e824ec86ddc47040ec559e03d8bf2b52592 SHA512 92b33d328ddf7e6f026a579cd00d01d7210e5aff91785cb5dd8244ea322daf78a57503de62db4f13413b7c3a57318f7c3c1a40d9e72e42de38539b4da15938e2
MISC metadata.xml 588 BLAKE2B 35668e32b10085ab7c76e803855150f34720e3862b49be9e7945a4f83be1fa3bbd324c42fbab63d8e76f71964a86cbfad1eccbf63eeb2c37dab57f896cb8066f SHA512 025fe962b70faee06d6a09532e8ab70b7513572f57d42052c97efa0955eb8f37e944989daed5f9dbe67f7ef155033280f8f2b40cdaaa6b3a8a824383de74a26d