summaryrefslogtreecommitdiff
path: root/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild')
-rw-r--r--dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..5d83f1ee0e10
--- /dev/null
+++ b/dev-perl/Gentoo-App-Pram/Gentoo-App-Pram-0.200.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MONSIEURP
+DIST_VERSION=0.200000
+
+inherit perl-module
+
+DESCRIPTION="Tool to merge PRs from the Gentoo Github repository"
+HOMEPAGE="https://github.com/monsieurp/Gentoo-App-Pram"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-vcs/git
+ virtual/perl-Encode
+ dev-perl/File-Which
+ dev-perl/Net-SSLeay
+ dev-perl/IO-Socket-SSL
+ virtual/perl-File-Temp
+ virtual/perl-HTTP-Tiny
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ !app-portage/pram"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ )"
+
+BDEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build-Tiny"