summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-DH-GMP
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-DH-GMP')
-rw-r--r--dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild42
-rw-r--r--dev-perl/Crypt-DH-GMP/Manifest2
-rw-r--r--dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch21
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
new file mode 100644
index 000000000000..30f27ae19248
--- /dev/null
+++ b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DMAKI
+DIST_VERSION=0.00012
+inherit perl-module
+
+DESCRIPTION="Crypt::DH Using GMP Directly"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="
+ >=dev-libs/gmp-4.0.0:0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.400.0
+ >=virtual/perl-Devel-PPPort-3.190.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-3.180.0
+ test? (
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.00012-no-dot-inc.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
diff --git a/dev-perl/Crypt-DH-GMP/Manifest b/dev-perl/Crypt-DH-GMP/Manifest
index 73c90a25c3d1..c2edbd73a642 100644
--- a/dev-perl/Crypt-DH-GMP/Manifest
+++ b/dev-perl/Crypt-DH-GMP/Manifest
@@ -1,3 +1,5 @@
+AUX Crypt-DH-GMP-0.00012-no-dot-inc.patch 437 BLAKE2B 74c94154a7cbd29035bb73a55431490e59fc188dfe228e4a5a84c920ebb1055d13adaec0a4d1288e350186e052fda6f4f85248701078d419cc42f7f331644f8c SHA512 5d7cd1a38987cf34b6be84b6a3171505c9ac134eb2f249e129ed419f0ec66224bd61d4105ab64644afe01094eeb8390d42c15dd805d74290722986c4c64a720e
DIST Crypt-DH-GMP-0.00012.tar.gz 34421 BLAKE2B 3d12f8a2f3950466fd21e5979e81a3a3e9a94f53e7f07790dbbe11728ccc3170ba9e49ba88f79a9f3487843d67071c77658341351b2551bce8603acfa68f9527 SHA512 f799017db780613b6d971f626659765f282debe63207bdbc36db223030bcd8f7f478c6331372d9794bcc8207d71bfae6d62048439766916478f4b61f42c5bb6e
+EBUILD Crypt-DH-GMP-0.0.120-r1.ebuild 771 BLAKE2B 1f8d449fe8fa9fdd17148124a166b59415a6c8309d25a9c49628380de2e63a374bb92393998a917300c0c325f714ae7b356b0517b9667d5c3e07dd4bc284859f SHA512 58cfa0aef5f948aec449da35d7b856a330f69e4492936e36165cb1773f2afaa6477b85907afaaec3d4eb3a08956dcb1261259e85b6ed51bc8e4cfc24a053fb50
EBUILD Crypt-DH-GMP-0.0.120.ebuild 789 BLAKE2B cff67840a6ff6a120115d58b786f54b153138de9ce84190626b5566dc58176b5e3db1a856728f81a707fcf386d7042b45ddcc9faefde7130be0bcb8c9a7f88a2 SHA512 ba59d95acfce30cce316bb276a2d27c7ca6dc3bda5a58cc7ee4246241eaccaff4cca80adeed900005d738125a7a374167402a35b947da2de806a53789cfaf932
MISC metadata.xml 466 BLAKE2B bf31d4a7dee193451c610c853ecaf7d0a5e18e9fc59a904eb1ac09e8b5f30398bc1d39ce576b130a44f01d79d98b812ca92f9b5f0fb2bea85d35df57ef35d7a6 SHA512 ed2f735cb8bf6ad21a1af6264acd17d57a90dabeb7aeabcd32e4f01bfa3a9bf70a691ddb9a14c8ec4361b909737c3831db2fef8154be7422bf733ba4467d29ca
diff --git a/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch b/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch
new file mode 100644
index 000000000000..81df0b2dc5ba
--- /dev/null
+++ b/dev-perl/Crypt-DH-GMP/files/Crypt-DH-GMP-0.00012-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 015df91fa006921333c47088d293845f8b8c38f9 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Jul 2020 06:31:46 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 8c03b4a..72cc677 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ my @DEFINES;
+--
+2.27.0
+