summaryrefslogtreecommitdiff
path: root/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild')
-rw-r--r--dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
new file mode 100644
index 000000000000..30f27ae19248
--- /dev/null
+++ b/dev-perl/Crypt-DH-GMP/Crypt-DH-GMP-0.0.120-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DMAKI
+DIST_VERSION=0.00012
+inherit perl-module
+
+DESCRIPTION="Crypt::DH Using GMP Directly"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-XSLoader-0.20.0
+ >=dev-libs/gmp-4.0.0:0
+"
+DEPEND="
+ >=dev-libs/gmp-4.0.0:0
+"
+BDEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.400.0
+ >=virtual/perl-Devel-PPPort-3.190.0
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ >=virtual/perl-ExtUtils-ParseXS-3.180.0
+ test? (
+ dev-perl/Test-Requires
+ virtual/perl-Test-Simple
+ )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.00012-no-dot-inc.patch"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}