summaryrefslogtreecommitdiff
path: root/dev-ml/res/res-4.0.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/res/res-4.0.7.ebuild')
-rw-r--r--dev-ml/res/res-4.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/res/res-4.0.7.ebuild b/dev-ml/res/res-4.0.7.ebuild
new file mode 100644
index 000000000000..60ad01e84ab7
--- /dev/null
+++ b/dev-ml/res/res-4.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://mmottl.github.io/res/"
+SRC_URI="https://github.com/mmottl/res/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}