summaryrefslogtreecommitdiff
path: root/dev-ml/res/res-4.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/res/res-4.0.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/res/res-4.0.7.ebuild')
-rw-r--r--dev-ml/res/res-4.0.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/res/res-4.0.7.ebuild b/dev-ml/res/res-4.0.7.ebuild
new file mode 100644
index 000000000000..60ad01e84ab7
--- /dev/null
+++ b/dev-ml/res/res-4.0.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://mmottl.github.io/res/"
+SRC_URI="https://github.com/mmottl/res/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}