summaryrefslogtreecommitdiff
path: root/dev-lisp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/Manifest.gzbin3379 -> 3377 bytes
-rw-r--r--dev-lisp/hyperspec/Manifest3
-rw-r--r--dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild35
-rw-r--r--dev-lisp/hyperspec/metadata.xml1
4 files changed, 38 insertions, 1 deletions
diff --git a/dev-lisp/Manifest.gz b/dev-lisp/Manifest.gz
index d8d06803f712..7573cd0d0dda 100644
--- a/dev-lisp/Manifest.gz
+++ b/dev-lisp/Manifest.gz
Binary files differ
diff --git a/dev-lisp/hyperspec/Manifest b/dev-lisp/hyperspec/Manifest
index b76b7ec104d6..2e10c1e6952f 100644
--- a/dev-lisp/hyperspec/Manifest
+++ b/dev-lisp/hyperspec/Manifest
@@ -1,3 +1,4 @@
DIST HyperSpec-7-0.tar.gz 2032830 BLAKE2B ec72b57fdcf669fe400dc2729191cc7c387172035d0663816fcc18450543052d3a958bd9042ef67bc70a1ccb07e74b189d32e1c790cdd1b721e8d74a6a88412d SHA512 1b9058fe1ae2e283f4a68211dc659021e04bd10373d7c2392f4fa496543e2454f96c7eb671bcb1e72c906456792f8a265a5e34bac24d01e2c0e7fb1ce359c370
EBUILD hyperspec-7.0-r2.ebuild 434 BLAKE2B fa7488beda86c36648aa9756e36b030cb1ca661d97860f87ee2d501c22a924fb916fde98e0c7f5ed97cf16584c4557cfa2fd6303b8c70077c46d48b03075ed25 SHA512 e90b88edb10526d52447566f97888009cde4da38ed78ba0487dd1d76965e0b56af315dce16c27e1366eb37d9cdfee22b4851823d9e2157cebe4ffed3fe86ce96
-MISC metadata.xml 261 BLAKE2B 161dea7ab371cbcbc08b8aac63e402f9fe994c08d55f2291360e900bf73e21f2c2ea67b6fcc3cb000f1cef03d1c41c6d2e5e16dd06d6916ec90d4e54a1ba3dd7 SHA512 fb754c4ed3579db5dbe303197a05647b7cfab0a3fe47fd2140d5f77641be752d10ccf49a9c267406a0f3ba3dcda8831f778b9596d723f65aff10142bfad60d3d
+EBUILD hyperspec-7.0-r3.ebuild 862 BLAKE2B 0b29f240d970113e291d7825a0987f386447bfb1cafe8cd7d0a9e496e797c03ab08c1446b56068aaac649a0be82e0ef0fc5d054b994e6a388457718259cac8e1 SHA512 e72268310fa1400a2484f288f85b31b65056b5d9f84214c471060924907c4f12c04137c9dc4ee2926c0ce8a4748ac7f3d3d4804f1daf42af5a9d10c03cc3ebb2
+MISC metadata.xml 284 BLAKE2B bdef133e2384ae8865f3ed1eb0a0ca29aeb421b55dcb53ac8dd9d1fedb9beb80dc545d707de50b89d07736cddf95fb30ca01701f0622d031ed26914fd4ad408c SHA512 4df84822911f4a0b5761dee19a3d58872a422d7636833d43eddb41b3623639e7f2e740683a497fd9e033e3a2d9605374ad599c4852282ab8edd761be212f9a01
diff --git a/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild b/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild
new file mode 100644
index 000000000000..750650047083
--- /dev/null
+++ b/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_PV=${PV/./-}
+MY_P=HyperSpec-${MY_PV}
+
+DESCRIPTION="Common Lisp ANSI-standard Hyperspec"
+HOMEPAGE="http://www.lispworks.com/reference/HyperSpec/"
+SRC_URI="ftp://ftp.lispworks.com/pub/software_tools/reference/${MY_P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="HyperSpec"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_install() {
+ docinto html
+ dodoc -r HyperSpec/{Body,Data,Front,Graphics,Issues}
+ dosym html /usr/share/doc/${PF}/HyperSpec
+ dosym -r /usr/share/doc/${PF} /usr/share/${PN}
+
+ docinto .
+ dodoc HyperSpec-{README,Legalese}.text
+ local DOC_CONTENTS="A permanent link to the HyperSpec documentation
+ is provided at: ${EPREFIX}/usr/share/${PN}"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-lisp/hyperspec/metadata.xml b/dev-lisp/hyperspec/metadata.xml
index 7ea645c67e72..d6374705e11a 100644
--- a/dev-lisp/hyperspec/metadata.xml
+++ b/dev-lisp/hyperspec/metadata.xml
@@ -5,4 +5,5 @@
<email>common-lisp@gentoo.org</email>
<name>Gentoo Common Lisp Project</name>
</maintainer>
+<stabilize-allarches/>
</pkgmetadata>