summaryrefslogtreecommitdiff
path: root/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild')
-rw-r--r--dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild b/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild
new file mode 100644
index 000000000000..750650047083
--- /dev/null
+++ b/dev-lisp/hyperspec/hyperspec-7.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_PV=${PV/./-}
+MY_P=HyperSpec-${MY_PV}
+
+DESCRIPTION="Common Lisp ANSI-standard Hyperspec"
+HOMEPAGE="http://www.lispworks.com/reference/HyperSpec/"
+SRC_URI="ftp://ftp.lispworks.com/pub/software_tools/reference/${MY_P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="HyperSpec"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_install() {
+ docinto html
+ dodoc -r HyperSpec/{Body,Data,Front,Graphics,Issues}
+ dosym html /usr/share/doc/${PF}/HyperSpec
+ dosym -r /usr/share/doc/${PF} /usr/share/${PN}
+
+ docinto .
+ dodoc HyperSpec-{README,Legalese}.text
+ local DOC_CONTENTS="A permanent link to the HyperSpec documentation
+ is provided at: ${EPREFIX}/usr/share/${PN}"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}