summaryrefslogtreecommitdiff
path: root/dev-lang/clips
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/clips')
-rw-r--r--dev-lang/clips/Manifest4
-rw-r--r--dev-lang/clips/clips-6.40.ebuild33
-rw-r--r--dev-lang/clips/files/clips-makefile-remove_hardcoded.patch33
-rw-r--r--dev-lang/clips/metadata.xml18
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-lang/clips/Manifest b/dev-lang/clips/Manifest
new file mode 100644
index 000000000000..1c4b9c7ffa75
--- /dev/null
+++ b/dev-lang/clips/Manifest
@@ -0,0 +1,4 @@
+AUX clips-makefile-remove_hardcoded.patch 758 BLAKE2B 6f41ad9787c62ff1918184afeee50dd58447f767270c6ad1edf90b72f17ddd593fc2b971d8004b82bd28657caeb6214bb3cddcc47895ec86de68064240c0a0d6 SHA512 724135392c0c8e5a315086963b5160bab6a93d5dfdf36bb373ff84d1c6773be0cdee956ad71bc6ca7a7e8f6f7dcfbdecdbf4cc3d8cf636b35f270771b9251d81
+DIST clips-6.40.tar.gz 1082012 BLAKE2B f168a14178ca0d5d39039d9e661e2214f9787099944e11413d7056b0c2a047596e913893a4cb3c4425c311af6bc39ff7710ce649045111e4947f5fcf320527c4 SHA512 92383895c60f1fa02a4c1f426d734ae7140e798dd19c7b1ee668bb4781a20e7d1f2554222ebc2c1f47c03d3262a7a058c3a7840d5dd48c2d2fe761e9a0602399
+EBUILD clips-6.40.ebuild 678 BLAKE2B 262f8adf45e7e74cdc1e82bb65b3607cd958576c4b8a3b82d7e6648f4ccae1fab5e40398c46a37e6c1ac057eeeeb0cfc79362b15adc93ee7e1f2f9e789b754ce SHA512 e712646d2b6d793d8a7fb47fd23d45002983d56fc7ac6e419f63b9dba0fa2be7565a0cf634b5c4fb35dab3453bb7c1e5a626546e56a08a4657edfc8ea78e1c5f
+MISC metadata.xml 676 BLAKE2B c2d78ba12c6ef855e1da73ba60e99db49ffa19ee050fab8e5f99085d60bacb8271ae9f09ecf2527f40da40c66cd9d09e269a8019a995dec899f01a3386235ddf SHA512 dc99a45fa946fb30b8477b191c728822dc42b6e18a5947042f8108ec0adc6e59885a0502be0278215f9d6a9eff741c39ee440baa905a4a9de8c5120cd043c108
diff --git a/dev-lang/clips/clips-6.40.ebuild b/dev-lang/clips/clips-6.40.ebuild
new file mode 100644
index 000000000000..e547eb971355
--- /dev/null
+++ b/dev-lang/clips/clips-6.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for building Expert Systems (native version)"
+HOMEPAGE="http://www.clipsrules.net/"
+
+CLPN="clips_core_source_$(ver_cut 1)$(ver_cut 2)"
+SRC_URI="https://sourceforge.net/projects/clipsrules/files/CLIPS/${PV}/${CLPN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${CLPN}/core"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile-remove_hardcoded.patch" )
+
+src_prepare() {
+ tc-export AR CC
+ default
+}
+
+src_compile() {
+ emake -f makefile
+}
+
+src_install() {
+ dobin clips
+ dolib.a libclips.a
+}
diff --git a/dev-lang/clips/files/clips-makefile-remove_hardcoded.patch b/dev-lang/clips/files/clips-makefile-remove_hardcoded.patch
new file mode 100644
index 000000000000..56d30660aaed
--- /dev/null
+++ b/dev-lang/clips/files/clips-makefile-remove_hardcoded.patch
@@ -0,0 +1,33 @@
+--- a/makefile
++++ b/makefile
+@@ -66,8 +66,10 @@ debug : CFLAGS = -std=c99 -O0 -g
+ debug : LDLIBS = -lm
+ debug : clips
+
+-release : CC = gcc
+-release : CFLAGS = -std=c99 -O3 -fno-strict-aliasing
++release : AR ?=
++release : CC ?=
++release : CFLAGS ?=
++release : LDFLAGS ?=
+ release : LDLIBS = -lm
+ release : clips
+
+@@ -88,14 +90,14 @@ release_cpp : LDLIBS = -lstdc++
+ release_cpp : clips
+
+ .c.o :
+- $(CC) -c -D$(CLIPS_OS) $(CFLAGS) $(WARNINGS) $<
++ $(CC) -c -D$(CLIPS_OS) $(CFLAGS) $(LDFLAGS) $<
+
+ clips : main.o libclips.a
+- $(CC) -o clips main.o -L. -lclips $(LDLIBS)
++ $(CC) -o clips main.o -L. -lclips $(CFLAGS) $(LDFLAGS) $(LDLIBS)
+
+ libclips.a : $(OBJS)
+ rm -f $@
+- ar cq $@ $(OBJS)
++ $(AR) cq $@ $(OBJS)
+
+ clean :
+ -rm -f main.o $(OBJS)
diff --git a/dev-lang/clips/metadata.xml b/dev-lang/clips/metadata.xml
new file mode 100644
index 000000000000..6c162346dc7e
--- /dev/null
+++ b/dev-lang/clips/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package is a pure C implementation of CLIPS.
+ CLIPS is a forward-chaining rule-based programming language written in C
+ that also provides procedural and object-oriented programming facilities.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://sourceforge.net/p/clipsrules/bugs/milestone/CLIPS/</bugs-to>
+ <remote-id type="sourceforge">clipsrules</remote-id>
+ </upstream>
+</pkgmetadata>