summaryrefslogtreecommitdiff
path: root/dev-lang/clips/clips-6.40.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/clips/clips-6.40.ebuild')
-rw-r--r--dev-lang/clips/clips-6.40.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/clips/clips-6.40.ebuild b/dev-lang/clips/clips-6.40.ebuild
new file mode 100644
index 000000000000..e547eb971355
--- /dev/null
+++ b/dev-lang/clips/clips-6.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for building Expert Systems (native version)"
+HOMEPAGE="http://www.clipsrules.net/"
+
+CLPN="clips_core_source_$(ver_cut 1)$(ver_cut 2)"
+SRC_URI="https://sourceforge.net/projects/clipsrules/files/CLIPS/${PV}/${CLPN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${CLPN}/core"
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile-remove_hardcoded.patch" )
+
+src_prepare() {
+ tc-export AR CC
+ default
+}
+
+src_compile() {
+ emake -f makefile
+}
+
+src_install() {
+ dobin clips
+ dolib.a libclips.a
+}