summaryrefslogtreecommitdiff
path: root/app-vim
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/Manifest.gzbin31746 -> 31579 bytes
-rw-r--r--app-vim/easytags/Manifest5
-rw-r--r--app-vim/easytags/easytags-3.11-r1.ebuild50
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild40
-rw-r--r--app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch54
-rw-r--r--app-vim/iris/Manifest3
-rw-r--r--app-vim/iris/iris-1.0.0.ebuild37
-rw-r--r--app-vim/iris/metadata.xml (renamed from app-vim/easytags/metadata.xml)5
-rw-r--r--app-vim/notes/Manifest3
-rw-r--r--app-vim/notes/metadata.xml11
-rw-r--r--app-vim/notes/notes-0.33.4-r1.ebuild35
-rw-r--r--app-vim/vim-nftables/Manifest2
-rw-r--r--app-vim/vim-nftables/vim-nftables-0_pre20200629.ebuild23
13 files changed, 69 insertions, 199 deletions
diff --git a/app-vim/Manifest.gz b/app-vim/Manifest.gz
index 69c784ffd199..6dc3766c3531 100644
--- a/app-vim/Manifest.gz
+++ b/app-vim/Manifest.gz
Binary files differ
diff --git a/app-vim/easytags/Manifest b/app-vim/easytags/Manifest
deleted file mode 100644
index 9f6c9c6edd1e..000000000000
--- a/app-vim/easytags/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX easytags-3.11-fix-ctags-detection.patch 2964 BLAKE2B eafaddd9877d8732eeace0197ab29cedba38a89a1f7c4e1fb2192cb075bc7a4541e6a5e5448a8944a7f6a0b47fb1cd481035529d6b11d5508df35089f2e85865 SHA512 f3ef6cfce5cbbebc4d33fc5f6fe0b7df037c9ec80da6f4a2b29bccb15e00b385719e654238f6becea1372900ac5f9e5e6d6af481537dde12c03cda24ee49e674
-DIST easytags-3.11.tar.gz 40572 BLAKE2B a6b228743f493bd467aff6685b6799de7e4862d384e14c81a084d7a211cf165d62cf902415a3c98a69858eded64c606bd4565f6e0c43fab7c078ba81d0ec5217 SHA512 9c1985a02b2718315d825ed29c06cbf78050e693893a9a7530a774031cbe9e6a27ee1dc91878950a1fbcaf7ea685faeb799d1e5b218b9ce25718783409f66130
-EBUILD easytags-3.11-r1.ebuild 1224 BLAKE2B d1784173bec8c978278e59586254b2bf6c9eaa9ac9ca744ff448eef65ae23f16d95476abd31d542ffdb2edbef70856142cc156bbb883bc57bfa93db6689fb370 SHA512 f1161fdfce9aa8ca733b25bb3ddcc187957e989b3b256fecdc4d314daa57e3b0979294d3ed2ad047748bbea48f573017531ba68df8270573e47cd4c2514760eb
-EBUILD easytags-3.11.ebuild 996 BLAKE2B c3211f023786914dc5d9c9f76cff7295cc8c3ead593438d74cb31565aee0f5c0a7057a6d2b3581d63a1bbcc2d2e5a70add77b2e84e3e78d7b9cab5478b3942f9 SHA512 c351e922c7d4656a1d92e2aaed798b125b40bee89a7e4d758ba0ea197a204b4905d5d8f017dcf5d781ee865350c68fddc2814a856ef3f16abf404486595274a8
-MISC metadata.xml 342 BLAKE2B 5e7e191544a04bc4ae28e482deef1c44c8ee11f6afe01d9ed6b138364f771411e341b5827e92bdfeae1edffdc166979c72a53034886530b0cdb55e34d9c2ce6e SHA512 0f4fbbedc023ccccc74ef8e020c3a90a0ccb0184164a52dd733699c5d4bf729d09478ea87fda093197679f7b44b3c1b64d3c64845d91d3fb92f9e3a1eab8fc78
diff --git a/app-vim/easytags/easytags-3.11-r1.ebuild b/app-vim/easytags/easytags-3.11-r1.ebuild
deleted file mode 100644
index cbd424d4f07a..000000000000
--- a/app-vim/easytags/easytags-3.11-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-vim/vim-misc
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-
- # fix scripts
- local f
- for f in $(find "${ED}" -type f -name \*.py); do
- ebegin "Fixing $(basename ${f})"
- if [[ $f =~ highlight.py ]]; then
- sed -e '1 i\#!/usr/bin/env python3' -i "${f}" || die "can't sed patch ${f}"
- fi
- 2to3 -w -n --no-diffs "${f}" >& /dev/null || die "can't convert ${f} to Python 3"
- python_fix_shebang -q -f "${f}"
- eend $?
- done
-}
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
deleted file mode 100644
index 3b3fa9986ce5..000000000000
--- a/app-vim/easytags/easytags-3.11.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=( "${FILESDIR}/${P}-fix-ctags-detection.patch" )
-
-src_prepare() {
- default
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- # fix scripts
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
- python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-}
diff --git a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch b/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
deleted file mode 100644
index 56b24dfe406f..000000000000
--- a/app-vim/easytags/files/easytags-3.11-fix-ctags-detection.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From f5746bdfd9942b00c349e53f3f4917ae73bb6797 Mon Sep 17 00:00:00 2001
-From: Mathias Andersson <wraul@dbox.se>
-Date: Thu, 24 Dec 2015 14:24:34 +0100
-Subject: [PATCH] Fix detection of Universal Ctags.
-
-Recently Universal Ctags changed version from 'Development' to '0.0.0'
-which broke the detection.
----
- autoload/xolox/easytags.vim | 32 +++++++++++++++++++-------------
- 1 file changed, 19 insertions(+), 13 deletions(-)
-
-diff --git a/autoload/xolox/easytags.vim b/autoload/xolox/easytags.vim
-index d0dec21..3c85e6a 100644
---- a/autoload/xolox/easytags.vim
-+++ b/autoload/xolox/easytags.vim
-@@ -78,19 +78,25 @@ function! xolox#easytags#check_ctags_compatible(name, min_version) " {{{2
- call xolox#misc#msg#debug("easytags.vim %s: Command '%s' returned nonzero exit code %i!", g:xolox#easytags#version, a:name, result['exit_code'])
- else
- " Extract the version number from the output.
-- let pattern = '\(Exuberant\|Universal\) Ctags \zs\(\d\+\(\.\d\+\)*\|Development\)'
-- let g:easytags_ctags_version = matchstr(get(result['stdout'], 0, ''), pattern)
-- " Deal with development builds.
-- if g:easytags_ctags_version == 'Development'
-- call xolox#misc#msg#debug("easytags.vim %s: Assuming development build is compatible ..", g:xolox#easytags#version, a:name)
-- return 1
-- endif
-- " Make sure the version is compatible.
-- if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-- call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-- return 1
-- else
-- call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ let pattern = '\(\w\+\) Ctags \(\d\+\(\.\d\+\)*\|Development\)'
-+ let match = matchlist(get(result['stdout'], 0, ''), pattern)
-+ let g:easytags_ctags_fork = match[1]
-+ let g:easytags_ctags_version = match[2]
-+ if g:easytags_ctags_fork != '' && g:easytags_ctags_version != ''
-+ call xolox#misc#msg#debug("easytags.vim %s: Detected %s Ctags %s", g:xolox#easytags#version, g:easytags_ctags_fork, g:easytags_ctags_version)
-+ if g:easytags_ctags_fork == 'Universal'
-+ " All versions should be compatible.
-+ call xolox#misc#msg#debug("easytags.vim %s: Assuming all versions is compatible ..", g:xolox#easytags#version)
-+ return 1
-+ elseif g:easytags_ctags_fork == 'Exuberant'
-+ " Make sure the version is compatible.
-+ if xolox#misc#version#at_least(a:min_version, g:easytags_ctags_version)
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is compatible! :-)", g:xolox#easytags#version)
-+ return 1
-+ else
-+ call xolox#misc#msg#debug("easytags.vim %s: Version is not compatible! :-(", g:xolox#easytags#version)
-+ endif
-+ endif
- endif
- endif
- call xolox#misc#msg#debug("easytags.vim %s: Standard output of command: %s", g:xolox#easytags#version, string(result['stdout']))
diff --git a/app-vim/iris/Manifest b/app-vim/iris/Manifest
new file mode 100644
index 000000000000..e1a92a380a5c
--- /dev/null
+++ b/app-vim/iris/Manifest
@@ -0,0 +1,3 @@
+DIST iris-1.0.0.tar.gz 15607 BLAKE2B f78155c7cdfce046c48f9a29ca2855212ebd5d7f5aabd7b3a605ca8257b1a99e6d0c005c3641f69a33f6d3b2335b2a68da9653c2487b4f5863ba96cc3323ee10 SHA512 0b8b74935c2844dbb874e18683fd65602820c13dfc50cc73425ac80440f898432eb1eb4af6e3b73cef5733ea9e7c1aa97d19f67e6d1a277592c359519dcc418c
+EBUILD iris-1.0.0.ebuild 868 BLAKE2B 21e76d1bbcef42f0ce7849a59e07a40ca0ea41e4632b54b307b602bd53669e662fbac2fcd2bbf2e9ce1921ed30e62096c455f6732aab982f60a041a5732359a5 SHA512 65a0ede037fc612a93fec8e5103711a3ab754877fed97ad37ff713c0e27cda8696febe81e4edd5f3c029b04654e257b48c4f17dc731bdd9d5d59335cee426c55
+MISC metadata.xml 424 BLAKE2B 16858ec2921c857270745dc135efa54ac2f1b8b1c4cf670b3daf210b55b8663d1d9ab49619d01fd7851a6aa0b511d88d18fa56154f057af68794e2d5ec9089e3 SHA512 5d47db34d2d1a4e93d710520e3bfb08ad4a023f59208e4363da5dc17d8c8dc0b623cef7619feafa9c7ed46c5ee0638cffecd72605a69608935068147ecddf960
diff --git a/app-vim/iris/iris-1.0.0.ebuild b/app-vim/iris/iris-1.0.0.ebuild
new file mode 100644
index 000000000000..8e10bcffdb96
--- /dev/null
+++ b/app-vim/iris/iris-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit vim-plugin python-r1
+
+MY_PN="iris.vim"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: mail client for vim"
+HOMEPAGE="https://github.com/soywod/iris.vim"
+SRC_URI="https://github.com/soywod/iris.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/imapclient
+ ${PYTHON_DEPS}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ mv api.py iris-api || die
+ mv idle.py iris-idle || die
+ sed -e 's#api\.py#iris-api#g;' -i autoload/iris/api.vim || die
+ sed -e 's#idle\.py#iris-idle#g;' -i autoload/iris/idle.vim || die
+ python_foreach_impl python_doscript iris-api
+ python_foreach_impl python_doscript iris-idle
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/easytags/metadata.xml b/app-vim/iris/metadata.xml
index f13cee8dc033..8ecaaddf7147 100644
--- a/app-vim/easytags/metadata.xml
+++ b/app-vim/iris/metadata.xml
@@ -5,7 +5,10 @@
<email>vim@gentoo.org</email>
<name>Gentoo Vim Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
<upstream>
- <remote-id type="github">xolox/vim-easytags</remote-id>
+ <remote-id type="github">soywod/iris.vim</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
deleted file mode 100644
index 9967f523bd97..000000000000
--- a/app-vim/notes/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST notes-0.33.4.tar.gz 239372 BLAKE2B f326c5d6adf25cce9261ac555541261750926c55f73d3a3f57885f7f03f9fae97e03f20882cb74f5fcd78b1ec06c2e0a5b1eb977aadf6a9771c679205a4a48e9 SHA512 7f2147e786582e69760c6d76d7144bc1fd0f8934ce6574184e16f463f5ca9c21e9e0fc87f88b56922b8195b26be7b0f99435cef773ccbc360077cf568b98b98a
-EBUILD notes-0.33.4-r1.ebuild 709 BLAKE2B a042e2ba158971a026b5dbdb11721510c2963a2ca44f7fc3407e6b70f6845427f9768057809d1916f7b1a1b55b7da4711808645f08de35a7aeb8fb50fac8adf0 SHA512 1f1bb3192f9504a9255c4210f0bd55cf8f951d4ae3206552a18043889ed0bc4e5f6414d3c5e755bf42b7853aa0ea1be25e3e8c24813ccaee669a52d8a29b95d3
-MISC metadata.xml 339 BLAKE2B 7d1ee9c5de677bd78ad2a5e0bca15deb9dc48bbfa56c7da216d47c0924fdab4e28c9db8878177471d2d4a7504770cf0395fd03a786d807971d07b61c31d8d7bb SHA512 ebc2c6981c7bb2ad9c8281e69d29203e5700bd5b930ee17feb16e5f1f581eb164971bcfc5584eb639404d70e2f13a3b8c51f4514759798ecc47ee8ec4776bbd1
diff --git a/app-vim/notes/metadata.xml b/app-vim/notes/metadata.xml
deleted file mode 100644
index 2e0c837525af..000000000000
--- a/app-vim/notes/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>vim@gentoo.org</email>
- <name>Gentoo Vim Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">xolox/vim-notes</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/app-vim/notes/notes-0.33.4-r1.ebuild b/app-vim/notes/notes-0.33.4-r1.ebuild
deleted file mode 100644
index d436975d1828..000000000000
--- a/app-vim/notes/notes-0.33.4-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-
-PYTHON_REQ_USE="sqlite"
-
-inherit vim-plugin python-single-r1
-
-DESCRIPTION="vim plugin: easy note taking in vim"
-HOMEPAGE="http://peterodding.com/code/vim/notes/"
-SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- app-vim/vim-misc"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-src_prepare() {
- default
-
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-
- python_fix_shebang "${S}"
-}
diff --git a/app-vim/vim-nftables/Manifest b/app-vim/vim-nftables/Manifest
index 8bd931a9cce7..4006c59023c7 100644
--- a/app-vim/vim-nftables/Manifest
+++ b/app-vim/vim-nftables/Manifest
@@ -1,3 +1,5 @@
DIST vim-nftables-0_pre20200224.tar.gz 2427 BLAKE2B a17780ffcabd1d323f3ccaa52e9726c2d8dc04583003fd8eaa799c897d1ccb1718a2ef28c2c06f0108785bdcc90addfb27d54f73db8d9f59b225e34c244cf179 SHA512 05dab5d9bdaed4ae1de9e00f2d6996f4350d859af73062d00417ee6567041c0a3fa6f50996fefa64e7a2410779b254ddeac1d5a893aa2f664504278b67fa2fd9
+DIST vim-nftables-0_pre20200629.tar.gz 2440 BLAKE2B 39a80bfa54b378896918f3703edd452cc3d9d15d15bc6545dfeda362726e8dc1bcfb1f2008d5c1236f24b01dbc17df59ea14928550a3567b57c74407c7e97d73 SHA512 71ddc55158b7461dc71730f76c84ba4cf76490afe0c5323502341e97d7173a1607e9cc70e6a552cfb7491e485352c837d0aa2e6f9c46e81ef525bedc88e389ef
EBUILD vim-nftables-0_pre20200224.ebuild 502 BLAKE2B 164a3201498bc9d2b9731257ec26c0fb7791a2c339c1a91e00d21dae349a902b415e5792c0bec89e5a2672681118ecca27a7c375cb584dece249e4b3c7b96a73 SHA512 26c2c3f39c08a4ac8ea2c5c63ceb62484bde70b847b6d4d013a56253955c4a9ee3a304dd612b8e2d6529ed8f677f04517069efc4d6a489f18d80a4a5b031830c
+EBUILD vim-nftables-0_pre20200629.ebuild 502 BLAKE2B f9d83816e66c852144476786018537c3481e3552e6e59aed4b03fb34d185907bcb6a7a6d2d817b1d6d94d688a61c93cdce7ad989b52ec4a17c15d7d32e2e3764 SHA512 1d64772cebb5ed368384c16c437644aa0ce3a395da028fe1c1f867bbd471c3760b75003e86b66225d0576c73b9fe6db4bfd4f2a8e5cc5b6de0189ef33bbec076
MISC metadata.xml 335 BLAKE2B e6d888e72998d7db2b4e8edfaeaa8de23bab3f0219feb2417efbbfc2eed225a462e261ba50330930e2b7f2dcbfba24423a6e7ed45c663e39c4a4d572f95e61e6 SHA512 6e1a94c30c49afdd2b7183033fac6c3dd47dd5bb6863a572a03634ec2f44ad520465b2cb1d677681ba23fc1235f3f5269b0783923f1d012ba5ab55e29dd2eef1
diff --git a/app-vim/vim-nftables/vim-nftables-0_pre20200629.ebuild b/app-vim/vim-nftables/vim-nftables-0_pre20200629.ebuild
new file mode 100644
index 000000000000..46857be2a72c
--- /dev/null
+++ b/app-vim/vim-nftables/vim-nftables-0_pre20200629.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_ID="26f8a506c6f3e41f1e4a8d6aa94c9a79a666bbff"
+
+DESCRIPTION="vim plugin: "
+HOMEPAGE="https://github.com/nfnty/vim-nftables"
+SRC_URI="https://github.com/nfnty/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_ID}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ # will install license file by default
+ rm LICENSE || die
+}