summaryrefslogtreecommitdiff
path: root/app-text/yamlfmt
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/yamlfmt')
-rw-r--r--app-text/yamlfmt/Manifest4
-rw-r--r--app-text/yamlfmt/metadata.xml11
-rw-r--r--app-text/yamlfmt/yamlfmt-0.12.1.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/yamlfmt/Manifest b/app-text/yamlfmt/Manifest
new file mode 100644
index 000000000000..445fad4a778a
--- /dev/null
+++ b/app-text/yamlfmt/Manifest
@@ -0,0 +1,4 @@
+DIST yamlfmt-0.12.1-deps.tar.xz 128404 BLAKE2B aa976bf73fb0a8094afc0ae480881aaff58c6263a57587ea6ceb22ce67776c424a7ed5d5fae6c38293f1ec5f3821de99e4bfd74f7951b826b2bb211914944c94 SHA512 11c9c45535ace449c3784a55707699923dcc2809db4f86a8fdb72b8b99443a92498b1c329cca40771d63414a6571bd4c590df4a304d798bb4c3709fd0edf0ef4
+DIST yamlfmt-0.12.1.tar.gz 40958 BLAKE2B 3a1187c2a21716a16e6c86ab145eed424bb3eb65ab8b0525c1ad221c27d8be3221f668f0393dcdc117bd4d34c9283bcc30e72ccddf99f61e44050c61e88b3026 SHA512 ac39234977d11751802a3a8c2e2140c16e408f987d29aa4ac8e7dd329067c1cef686b0950fa4e4478aeeb214506e7d3fe498734e584abcbc4f3aa48f9f1c7504
+EBUILD yamlfmt-0.12.1.ebuild 663 BLAKE2B 981735baeef8058e26ae928d73720bea700e577f144a7a2cf5854f34c164997d4c1ebcab5167d6ed402b1786e621a17d4c21b2f8e20319a7b85e92ed568430ab SHA512 6e4fa2a212195ecb721fc1dfe6837a9ee416c10693109b3bf3e6e6b0314b04378a2b4d54e925a99924d65c5a4fde24b98a0f88eb0b24bc5b95e4b610b06b7407
+MISC metadata.xml 324 BLAKE2B 0a0b464b24dad8d5433b23e2b5255257ccc488ecdbf94cdf2b74e9dfd6e6782d56e2fd248746333a2635c5346aabe1ba128d7cb8994430eda6478f25b702971a SHA512 b7b9a79c5bf61b7639b145ee85758d517d91ab234106aa8ff552eb29934d466f311a9ec966b665c5aefd956b5d017568125a040adf2f4f62781608beeb3b155a
diff --git a/app-text/yamlfmt/metadata.xml b/app-text/yamlfmt/metadata.xml
new file mode 100644
index 000000000000..d69deed03841
--- /dev/null
+++ b/app-text/yamlfmt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/yamlfmt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/yamlfmt/yamlfmt-0.12.1.ebuild b/app-text/yamlfmt/yamlfmt-0.12.1.ebuild
new file mode 100644
index 000000000000..5f85ed96ccb4
--- /dev/null
+++ b/app-text/yamlfmt/yamlfmt-0.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="An extensible command line tool or library to format yaml files"
+HOMEPAGE="https://github.com/google/yamlfmt"
+SRC_URI="https://github.com/google/yamlfmt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+LICENSE+=" BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ CGO_ENABLED=0 ego build -ldflags "-X main.version=${PV} -s -w" \
+ -o yamlfmt ./cmd/yamlfmt
+}
+
+src_install() {
+ dodoc -r README.md docs
+ dobin yamlfmt
+}
+
+src_test() {
+ emake test
+}