summaryrefslogtreecommitdiff
path: root/app-text/yamlfmt/yamlfmt-0.12.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/yamlfmt/yamlfmt-0.12.1.ebuild')
-rw-r--r--app-text/yamlfmt/yamlfmt-0.12.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-text/yamlfmt/yamlfmt-0.12.1.ebuild b/app-text/yamlfmt/yamlfmt-0.12.1.ebuild
new file mode 100644
index 000000000000..5f85ed96ccb4
--- /dev/null
+++ b/app-text/yamlfmt/yamlfmt-0.12.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="An extensible command line tool or library to format yaml files"
+HOMEPAGE="https://github.com/google/yamlfmt"
+SRC_URI="https://github.com/google/yamlfmt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+LICENSE+=" BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ CGO_ENABLED=0 ego build -ldflags "-X main.version=${PV} -s -w" \
+ -o yamlfmt ./cmd/yamlfmt
+}
+
+src_install() {
+ dodoc -r README.md docs
+ dobin yamlfmt
+}
+
+src_test() {
+ emake test
+}