summaryrefslogtreecommitdiff
path: root/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch')
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
new file mode 100644
index 000000000000..5ccef2047bc7
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -0,0 +1,14 @@
+--- hexcompare-1.0.4/Makefile
++++ hexcompare-1.0.4/Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
++CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+
+ all: hexcompare
+
+ hexcompare: main.c gui.c
+- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
++ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
+
+ clean:
+ rm -f *.o